Export leaves an empty *.tmp file behind

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Export leaves an empty *.tmp file behind

Post by ckv » Tue Feb 18, 2020 4:03 pm

Very minor old bug.

The File/Export tool creates two .tmp files (<rand>.tmp and <rand>.tmp.tmp) in the temp directory each time you use it. Temp file with the double extension (<rand>.tmp.tmp) is the one that XnView actually uses and deletes afterwards, but the <rand>.tmp file that is not used is never deleted by XnView.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Export leaves an empty *.tmp file behind

Post by xnview » Thu Feb 27, 2020 11:24 am

i can't reproduce, you open a file in edit mode, File>export - jpeg, close dialog, and you have .tmp?
Pierre.

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Export leaves an empty *.tmp file behind

Post by ckv » Fri Feb 28, 2020 11:41 am

xnview wrote:
Thu Feb 27, 2020 11:24 am
i can't reproduce, you open a file in edit mode, File>export - jpeg, close dialog, and you have .tmp?
Yes, exactly. Zero-length .tmp file in the %temp% directory.

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Export leaves an empty *.tmp file behind

Post by ckv » Wed Apr 22, 2020 8:51 pm

I think that Windows Storage Sense (new feature in Windows 10) may get in the way when trying to reproduce this issue. Try disabling Storage Sense on Windows 10 or try on older Windows version.

Post Reply