Can't view JPG file by using XnView

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

ppp1024
Posts: 1
Joined: Wed Sep 21, 2005 3:45 am

Can't view JPG file by using XnView

Post by ppp1024 » Wed Sep 21, 2005 5:09 am

I haved install latest version of XnView
When i double click JPG file's icon , XnView Browser can't popup !
But xnview.exe still work in windows task manager !
It is so strange.....
To open GIF file with XnView by double clicking gif file's icon, everything is ok !! Xnview Browser work's all right !!
Any one know how to solve this problem??

User avatar
xnview
Author of XnView
Posts: 31360
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: I Can't view JPG file by useing Xnview

Post by xnview » Wed Sep 21, 2005 9:06 am

ppp1024 wrote:I haved install latest version of Xnview
When i double click JPG file's icon , Xnview Browser Can't popup !
But xnview.exe still work in windows task manager !
It is so strange.....
To open GIF file with Xnview by doubale clicking gif file's icon , everything is ok !! Xnview Browser work's all right !!
Any one know how to solve this problem??
Could you try to uninstall it, and install again the 1.80.3 setup
Pierre.

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken » Wed Sep 21, 2005 12:17 pm

Was the JPG created by photoshop? If so, reopen it in photoshop and the re-save it using the save for web feature, then try opening the new JPG in xnview.

Also, have you tried opening xnview first, then opening the JPG from the file->open dialog?

confidant

view problem

Post by confidant » Mon Sep 26, 2005 3:39 pm

Hi everybody,
I have same problem too. I have uninstalled xnviewer and reinstalled it but I cannot see the pictures by double clicking them. It is working in task manager but there is no scene. Beside this, they are not photosop files. What can ı do?
Thanks,

User avatar
xnview
Author of XnView
Posts: 31360
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: view problem

Post by xnview » Mon Sep 26, 2005 4:31 pm

confidant wrote:I have same problem too. I have uninstalled xnviewer and reinstalled it but I cannot see the pictures by double clicking them. It is working in task manager but there is no scene. Beside this, they are not photosop files. What can ı do?
It's very strange, some users have this problem, but i don't understand why.

There is a bad key in registry, please remove -slide from:
HKEY_CLASSES_ROOT\Applications\xnview.exe\shell\open\command
"C:\Program Files\XnView\xnview.exe" -slide "%1"

Correct is:
HKEY_CLASSES_ROOT\Applications\xnview.exe\shell\open\command
"C:\Program Files\XnView\xnview.exe" "%1"

Note: Your program path may differ, keep your program path.
Pierre.

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken » Mon Sep 26, 2005 9:28 pm

What version of windows are you guys using? Perhaps that's where the problem lies.
I did have a similar problem with v1.7x (I think it was 1.74, but I'm not certain) and WBZ files. They would open without any difficulties if I opened xnview first and then opened them from within xnview, but if I just double clicked the files, xnview would give me some error. I was on win98 at the time.

Guest

Post by Guest » Tue Sep 27, 2005 9:06 am

Thanks I lot Admin,

When I have changed the registry key "C:\Program Files\XnView\xnview.exe" -slide "%1" to "C:\Program Files\XnView\xnview.exe" "%1" the problem was solved.

Regards,

Wisdom

Good work

Post by Wisdom » Tue Oct 04, 2005 3:08 pm

Thanks removing the -slide worked.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Problem can be recreated

Post by marsh » Mon May 15, 2006 6:11 am

A way to recreate registry problem:
1. Start with no Xnview references to it in registry.
2. Make the first and only association you make:
[x]Associate slide file with Xnview
3. Close Xnview.
4. Select unassociated image in MS explorer.
5. Now use MS explorer's Open with function to choose Xnview from list of programs.
6. *The bad key will now be associated with Xnview.

User avatar
xnview
Author of XnView
Posts: 31360
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem can be recreated

Post by xnview » Mon May 15, 2006 7:13 am

marsh wrote:A way to recreate registry problem:
1. Start with no Xnview references to it in registry.
2. Make the first and only association you make:
[x]Associate slide file with Xnview
3. Close Xnview.
4. Select unassociated image in MS explorer.
5. Now use MS explorer's Open with function to choose Xnview from list of programs.
6. *The bad key will now be associated with Xnview.
Oh, thanks :-) i'll check
Pierre.

Latice

Doubleclick on JPEG files does not display them in XnView

Post by Latice » Mon Sep 11, 2006 2:44 pm

Just to let you know that I also experienced the bad registry key problem which prevents to have XnView open properly when double-clicking on JPEG files in MS Windows Explorer (although proper association of XnView to open JPEG files was made in MS Windows Explorer).

My configuration is as follow:
- MS Windows 2000 SP4
- XnView 1.82.4

Removing the -slide in the registry key fixed the problem. Thank you for this piece of info.

JCB

Post by JCB » Wed Sep 13, 2006 1:52 pm

same problem for me, with windows 2000 SP4. The solution "no slide registry" is ok. Strange problem !
Thanks

pstein
Posts: 51
Joined: Mon Sep 04, 2006 3:43 pm

Post by pstein » Thu Nov 02, 2006 7:55 am

Same problem for me:

MS Windows 2000 SP4 + XnView 1.82.4

After removing -slide doubleclick worked as intended.

Maybe its Win2000 specific

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Nov 29, 2006 8:33 pm

@Pierre: Will this be fixed in 1.90? (I think a bug fix is very important).

User avatar
xnview
Author of XnView
Posts: 31360
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Nov 30, 2006 7:32 am

helmut wrote:@Pierre: Will this be fixed in 1.90? (I think a bug fix is very important).
For me, it has been fixed in 1.90
Pierre.

Post Reply