This JPG Crashes XNView

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

This JPG Crashes XNView

Post by JohnFredC »

The link below is to a moderate-sized (0.75Mb) JPG that does not display properly in XNView and, if zoomed, will crash XNView.

http://www.jfcinc.net/images/misc/img_5684.jpg

Can anyone else reproduce this? It displays properly in every other graphics software I have tried.

Sorry about the size of the file.

XnView 1.82 RC3
John
User avatar
Stitscher
Posts: 45
Joined: Thu Dec 01, 2005 10:01 pm
Location: Hamburg, Germany

Post by Stitscher »

Sorry, I can not confirm this behavior.
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Post by JohnFredC »

Here is what that image looks like in XNView (It's the vertical line in the center).

Zooming in from here crashes XNview.

Image
John
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Post by JohnFredC »

Notice that the tab's thumbnail is correctly displayed!
John
User avatar
Stitscher
Posts: 45
Joined: Thu Dec 01, 2005 10:01 pm
Location: Hamburg, Germany

Post by Stitscher »

No problems here!
Image
Image
User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv »

I can't confirm. Work perfectly in RC3, RC2 and 1.80.3. Have you tried to rename your xnview.ini?
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Post by JohnFredC »

Have you tried to rename your xnview.ini?
Well, no, I hadn't. Why would that make a difference? :wink:

On the other hand renaming the INI worked!

Totally bizaare. It was just this one image with the problem. I have worked with over an hundred jpgs today.

Any idea which INI setting is the culprit so I don't have to start over setting options from scratch?

Oh, and thanks!
John
User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv »

Nope. Unfortunately setting aren't backward compatible and using old ini files can easily cause problems. :| But if you wasn't using old ini (your ini was created by RC3) then there might be a bug and I am sure Pierre would be interested to that ini file.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.
User avatar
xnview
Author of XnView
Posts: 34089
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview »

ckv wrote:Nope. Unfortunately setting aren't backward compatible and using old ini files can easily cause problems. :| But if you wasn't using old ini (your ini was created by RC3) then there might be a bug and I am sure Pierre would be interested to that ini file.
Yes, please send me it...
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

OK here…

Post by Clo »

:arrow: JohnFredC

:) Your pic is displayed perfectly here with 1.80.3, and also with 1.82 RC3… for which I didn't rebuilt the INI at all since the beta versions !

- No crash, zoom in¦out at will up¦down to maxi¦mini no problem…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Post by JohnFredC »

2xnview

Hi Pierre...

I sent the problem INI (associated with the above report) to the support email address yesterday.
John
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

I can't confirm the bug.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

No problems to view the image, here. (XP SP2, XnView 1.82 RC3)
Post Reply