F5 does not recognice Exif-Thumbnail change.

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

F5 does not recognice Exif-Thumbnail change.

Post by brotondi »

[x] Use embedded Exif-Thumbnail
Update Exif-Thumbnail with 3rd-Party-Tool (or rotate with 2nd XNView)
Press F5: The Thumbs will flicker but not be changed
(This is the Bug)

Now Change "View/Thumbnail Size" -> All Thumbnails will be updated and now be correct.
(This is the control)

... Only a little bug but if you add an Exif-Updater it will get important.

Greetings, Bruno
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: F5 does not recognice Exif-Thumbnail change.

Post by xnview »

brotondi wrote:[x] Use embedded Exif-Thumbnail
Update Exif-Thumbnail with 3rd-Party-Tool (or rotate with 2nd XNView)
Press F5: The Thumbs will flicker but not be changed
(This is the Bug)

Now Change "View/Thumbnail Size" -> All Thumbnails will be updated and now be correct.
(This is the control)

... Only a little bug but if you add an Exif-Updater it will get important.
It's not really a bug because the embedded thumbnail is not changed....
Pierre.
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

??? don't know what happened, now I cannot reproduce it too...

it seemed, that XnView was not able to re-read the Exif-Thumbnail, even after a change... but now everything is o.k.

...

when it happens againg I must have a sharper look on what happened really...

Have a nice day!

Bruno
burdiman

same problem

Post by burdiman »

I set up a new PC and installed this new version of xnview. I previously used the last version of xnview and this new version is not recognizing the flipped thumbnails but the full sized images are oriented correctly. Weird.

The thumbnail size trick works but this is annoying.
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

Hi

You must know:
-In Exif there's an orientation flag AND the thumbnail
-But there is no relation between them.

If a tool turns the thumbnail but does not set back the Flag (I think some older XnView-Versions) this will happen.

(I Think this is what you saw)

Bruno
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

FAQ "How to rotate images automatically" describes burdimans's problem and what you can do about it.
Post Reply