Initial size of XnView window and panes

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Initial size of XnView window and panes

Post by helmut » Mon Dec 04, 2006 9:34 pm

When starting XnView for the very first time, the main window's size is 640x480. And the tree pane's net width is 48 pixel. When resizing the main window, the tree pane's width does not change.

These values are far from being optimal. The tree pane with 48 pixels width is not usable. Since the explorer/tree pane's size does not change when resizing the main window, it should be much larger. Otherwise every single user will have to start with resizing the tree pane - assuming that the user knows. Those people who don't know will be in trouble right from start of XnView.

Suggestions:
- The tree pane's initial width should be about 160 pixel in width.

- If no setting for XnView's window size is available, XnView should determine the screen's size automatically and size the main window to about 75% of the screen size.

User avatar
xnview
Author of XnView
Posts: 30112
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Initial size of XnView window and panes

Post by xnview » Tue Dec 05, 2006 9:23 am

helmut wrote:When starting XnView for the very first time, the main window's size is 640x480. And the tree pane's net width is 48 pixel. When resizing the main window, the tree pane's width does not change.

These values are far from being optimal. The tree pane with 48 pixels width is not usable. Since the explorer/tree pane's size does not change when resizing the main window, it should be much larger. Otherwise every single user will have to start with resizing the tree pane - assuming that the user knows. Those people who don't know will be in trouble right from start of XnView.

Suggestions:
- The tree pane's initial width should be about 160 pixel in width.
Strange, the tree pane has a width of 180 at the first start....
- If no setting for XnView's window size is available, XnView should determine the screen's size automatically and size the main window to about 75% of the screen size.
Right
Pierre.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Initial size of XnView window and panes

Post by helmut » Tue Dec 05, 2006 9:02 pm

xnview wrote:Strange, the tree pane has a width of 180 at the first start....
I've just remove the xnview.ini and XnView has created a new one right after exiting. It has written "TreeViewWidth=56".

Could some other people please check?

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Tiny !

Post by Clo » Tue Dec 05, 2006 10:14 pm

• Hi !

• I've moved the INI to a backup sub-dir, and starting ß-2 I get a tiny tree-zone as 52 pixels width inside,
including the vertical scroll-bar !
- There are horizontal scroll-bar buttons too.

• But strangely, I don't find the "fresh" INI anywhere to check the entry you quote !

• Aside, when making such an operation, all versions installed here (4) take the same look !
Their own INIs are no more used…
- This is indeed another issue to solve, I'll try to parse it further (the single Registry key might be the culprit !)

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Tiny !

Post by helmut » Tue Dec 05, 2006 10:23 pm

Clo wrote:• I've moved the INI to a backup sub-dir, and starting ß-2 I get a tiny tree-zone as 52 pixels width inside,
including the vertical scroll-bar !
- There are horizontal scroll-bar buttons too.
Thank you for reproducing. You have the same result as I have.
Clo wrote:• But strangely, I don't find the "fresh" INI anywhere to check the entry you quote ! ...
This has confused me a bit, too. If XnView does not find an .ini file in the program folder, it will search and save the .ini file in the users application data area. (e.g. C:\Documents and folders\<User>\Application Data\XnView.).

If you want this to change you have to change the setting in Tools > Options > System integration > Save options.

User avatar
XnTriq
Moderator & Librarian
Posts: 5318
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Initial size of XnView window and panes

Post by XnTriq » Tue Dec 05, 2006 10:25 pm

helmut wrote:
xnview wrote:Strange, the tree pane has a width of 180 at the first start....
I've just remove the xnview.ini and XnView has created a new one right after exiting. It has written "TreeViewWidth=56".

Could some other people please check?
OK, I get “TreeViewWidth=200” in XnView 1.90 beta 2 on Windows 2000 SP4 with 1024×768px screen resolution.

Before testing, did you delete or remove all INI files?
  • \%PROGRAMFILES%\XnView\xnview.ini
    \%APPDATA%\XnView\xnview.ini
    \%SYSTEMROOT%\xnview.ini
How about the registry?
  • HKEY_CURRENT_USER\Software\XnView

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Ghost INI !

Post by Clo » Tue Dec 05, 2006 10:34 pm

• Again…

• Here, the path is :
E:\Documents and Settings\CLAUDE\Application Data\XnView\
but there is not any INI there ! I checked in the folders of the other versions, and in Windows too, nope !
- It seems that by default here (G. only knows why!) the settings come¦are saved from¦in the Registry ! :shock:

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Initial size of XnView window and panes

Post by helmut » Tue Dec 05, 2006 10:35 pm

XnTriq wrote:OK, I get “TreeViewWidth=200” in XnView 1.90 beta 2 on Windows 2000 SP4 with 1024×768px screen resolution.

Before testing, did you delete or remove all INI files?
I work with 1280 x 1024px screen resolution. I've temporarily changed resolution to 1024x768 with the same result: The explorer/tree pane is very narrow.

In XnView 1.82 this works fine, size of tree pane is wide enough.

User avatar
xnview
Author of XnView
Posts: 30112
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Initial size of XnView window and panes

Post by xnview » Wed Dec 06, 2006 12:27 pm

helmut wrote:
XnTriq wrote:OK, I get “TreeViewWidth=200” in XnView 1.90 beta 2 on Windows 2000 SP4 with 1024×768px screen resolution.

Before testing, did you delete or remove all INI files?
I work with 1280 x 1024px screen resolution. I've temporarily changed resolution to 1024x768 with the same result: The explorer/tree pane is very narrow.

In XnView 1.82 this works fine, size of tree pane is wide enough.
You must have a xnview.ini somewhere for 1.90, the default value for TreeViewWidth is 200.
But it's true that the size for xnview must be around 75% of screen the first time...
Pierre.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Initial size of XnView window and panes

Post by helmut » Wed Dec 06, 2006 11:22 pm

xnview wrote:You must have a xnview.ini somewhere for 1.90, the default value for TreeViewWidth is 200.
But it's true that the size for xnview must be around 75% of screen the first time...
I have many xnview.ini files on my box, but I'm pretty sure that I keep removing the correct one before restarting XnView. Or does XnView 1.90 read an .ini file but write it to a different location? And XnView's window size is 640x480 when starting for the first time, I think this is an indication that I remove the correct .ini file. Just the tree pane is not wide enough.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Thu Dec 07, 2006 12:18 am

TreeViewWidth is 200 for me. Only XP users are reporting 56... so far

ckit
XnThusiast
Posts: 2438
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah Australia
Contact:

Post by ckit » Thu Dec 07, 2006 12:28 am

Mine is about 63-64 with a new INI config.
Win10 Pro x64 RS4 1803, Malwarebytes Premium, Process Lasso Pro
XnView Classic and PhotoFiltre Studio X

User avatar
xnview
Author of XnView
Posts: 30112
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Dec 07, 2006 9:37 am

ckit wrote:Mine is about 63-64 with a new INI config.
Very strange, i have always 200 with a new .ini on 2K or Xp
Pierre.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Thu Dec 07, 2006 11:01 pm

Somethings seems to be going wrong, here.

@Pierre: I hope you can find and fix the bug. Let us know if you need more input.

User avatar
xnview
Author of XnView
Posts: 30112
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Dec 08, 2006 6:50 am

helmut wrote:Somethings seems to be going wrong, here.

@Pierre: I hope you can find and fix the bug. Let us know if you need more input.
Really i think that you have an old .ini, could you check with B3
Pierre.

Post Reply