ICL files crash, feature requests

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

patrickang
Posts: 6
Joined: Tue Apr 20, 2004 7:41 am

ICL files crash, feature requests

Post by patrickang » Tue Apr 20, 2004 9:53 am

Hi,

First of all, thanks for a great product.

Found a bug (?):
- When viewing .ICL file, I get the Windows blue screen (exception).

Feature requests:
- In the "Multiple File Convert" dialog, the Directory is always blank when the dialog is showed. Can it retain the last used directory?
- Can the applications listed in the "Open with" popup be renamed? (eg. instead of Mspaint, Microsoft Paint)
- When viewing .ICO files, I get a black background. Can I change this? or use the background color (like in transparent GIFs)

Thanks again!

System: Windows 98 SE; XnView 1.68.1

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: ICL files crash, feature requests

Post by helmut » Wed Apr 21, 2004 5:47 am

patrickang wrote:... Found a bug (?):
- When viewing .ICL file, I get the Windows blue screen (exception). ...
There was a problem with ICL files in previous versions of XnView, but this has been fixed in Version 1.68 (or even an earlier version).

Could please mail a sample Icon Library file to Pierre or upload it onto a webserver and post a link to the ICL file here?

patrickang
Posts: 6
Joined: Tue Apr 20, 2004 7:41 am

Post by patrickang » Mon Apr 26, 2004 3:45 am

Hi,

Tried the ICLs i have with version 1.66 and they opened fine.

I've sent a sample via mail.

Thanks!

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Mon Apr 26, 2004 5:50 am

patrickang wrote:Tried the ICLs i have with version 1.66 and they opened fine.
Thanks for your feedback, so this is really fixed in XnView 1.68. :-)
patrickang wrote:I've sent a sample via mail.
Thanks, since it works there's no need for a sample anymore.

patrickang
Posts: 6
Joined: Tue Apr 20, 2004 7:41 am

Post by patrickang » Mon Apr 26, 2004 10:04 am

helmut wrote: Thanks for your feedback, so this is really fixed in XnView 1.68.
Hi,

Sorry I wasn't clear. What I meant was the files opened fine with v1.66 but raised exceptions with v1.68.x.

But after opening a couple more ICLs with v1.66, I got the blue screen too. :)

Thanks!

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Apr 28, 2004 4:57 pm

patrickang wrote: Sorry I wasn't clear. What I meant was the files opened fine with v1.66 but raised exceptions with v1.68.x.

But after opening a couple more ICLs with v1.66, I got the blue screen too.
You have sent a sample to Pierre, so he knows now and will fix the problem occasionally.
Last edited by helmut on Thu Apr 29, 2004 6:12 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 32746
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Apr 29, 2004 4:27 am

You have sent a sample to Pierre, so he knows now and will fix the problem occasionally.
No, i have not received his ICL file!
Pierre.

patrickang
Posts: 6
Joined: Tue Apr 20, 2004 7:41 am

Post by patrickang » Thu Apr 29, 2004 4:39 am

xnview wrote: No, i have not received his ICL file!
I have just re-sent it to #####. Thanks Pierre! :D

Patrick

User avatar
xnview
Author of XnView
Posts: 32746
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Apr 29, 2004 11:30 am

patrickang wrote:
xnview wrote: No, i have not received his ICL file!
I have just re-sent it to #####. Thanks Pierre!
Patrick
When do you have the crash?
I've tested on windows 98SE, and no problem :-(
Pierre.

patrickang
Posts: 6
Joined: Tue Apr 20, 2004 7:41 am

Post by patrickang » Mon May 03, 2004 5:05 pm

xnview wrote: When do you have the crash?
I've tested on windows 98SE, and no problem :-(
It crashes when:
1. I use the Browser (thumbnail viewer) to view a folder containing the ICL file
2. I tried to view the ICL file and navigate through the icons using the Next/Prev page buttons.

Both crashes after a few (10?) seconds. Tried it on 2 different computers (office & home), both running Win98SE and same results.

Sam

old, old trouble

Post by Sam » Sat Oct 09, 2004 7:08 am

System: Windows 98 SE; XnView 1.70.4

Open in Browser (thumbnail or detail mode) icl file -> Windows blue screen.
Example: http://zapatopi.net/icon/archaeologicons.zip

Heading of a file:
------------ Archaeologicons.icl ----------------------
4D 5A 00 00-00 00 00 00-00 00 00 00-00 00 00 00 MZ
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 00 00-00 00 00 00-00 00 00 00-80 00 00 00 À
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 00 00-00 00 00 00-00 00 00 00-00 00 49 4D IM
4E 45 00 00-00 00 00 00-00 00 00 00-00 00 00 00 NE
00 00 00 00-00 00 00 00-00 00 00 00-00 00 00 00
00 00 40 00-40 00 8C 07-00 00 00 00-00 00 00 00 @ @ Ì
------------ Archaeologicons.icl ----------------------

User avatar
xnview
Author of XnView
Posts: 32746
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: old, old trouble

Post by xnview » Sat Oct 09, 2004 9:11 am

I'll test. The problem occurs in 98 & Xp?
Pierre.

Sam

Re: old, old trouble

Post by Sam » Sat Oct 09, 2004 10:23 am

xnview wrote:I'll test. The problem occurs in 98 & Xp?
Only in 98.

Sam

Re: old, old trouble

Post by Sam » Tue Oct 12, 2004 11:42 am

XnView 1.74.
The problem has remained...
Help!

Sam

Re: old, old trouble

Post by Sam » Tue Nov 02, 2004 8:22 am

The problem is not solved basically?

Post Reply