moving quickly through folders is not possible anymore?

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

moving quickly through folders is not possible anymore?

Post by loth »

hi all,

i'm not quite sure about this,
did anybody recognize the loss of this wonderful m$-explorer-feature to walk through the files in a folder with simply typing the starting letters of the filenames, in xnview?

-go to browsermode (in my case: a folder with 50 directories, all starting with "A", like "Abnormal", "Andromeda", "Art" ...)
-press (in a fast way) "a" + "r" and move quite quickly to the folder "Art" (if it is the first one which is named "Ar...")

as i said, i'm not quite sure, if xnview had this feature, but i think it had.
now it is gone.
why?
loth
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Nice here…

Post by Clo »

—> loth

:) Hello !

- It works perfectly here, I tested with a board of thumb-nails, no problems !

• Maybe some setting has been changed for you in Win$ - by some new program, perhaps- ?
- Normally, this works in almost all apps. …

- Win XP-Pro - XnView 1.82.4

:mrgreen: VG
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Re: Nice here too...

Post by loth »

Clo wrote:It works perfectly here, I tested with a board of thumb-nails, no problems
hmmm...it works on m$-explorer here, not in xnview.
but if i go to the "open"-dialog inside xnview, it works (must be a call of an explorer function or somewhat...)
Clo wrote:Maybe some setting has been changed for you in Win$ - by some new program, perhaps- ?
this happend to me on two (XPpro sp2) computers. same xnview version (v1.82.4), of course, i copied the program-dir.
i delete the xnview.ini and started from scratch. no change.
also, i downloaded the "XnView v1.82.4 Complete version (Plugins & NConvert) Zip file (Multi-language)", extracted and started xnview.exe to test it. no change.

it won't work here.
loth
User avatar
xnview
Author of XnView
Posts: 33872
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: moving quickly through folders is not possible anymore?

Post by xnview »

loth wrote:hi all,

i'm not quite sure about this,
did anybody recognize the loss of this wonderful m$-explorer-feature to walk through the files in a folder with simply typing the starting letters of the filenames, in xnview?

-go to browsermode (in my case: a folder with 50 directories, all starting with "A", like "Abnormal", "Andromeda", "Art" ...)
-press (in a fast way) "a" + "r" and move quite quickly to the folder "Art" (if it is the first one which is named "Ar...")

as i said, i'm not quite sure, if xnview had this feature, but i think it had.
now it is gone.
why?
Because the $soft liview control has many problems, so now in thumbnail mode, this doesn't work anymore...
Pierre.
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Re: moving quickly through folders is not possible anymore?

Post by loth »

xnview wrote:Because the $soft liview control has many problems, so now in thumbnail mode, this doesn't work anymore...
hmm...so this is a known issue?
and it means, that it is not working on every system anymore? or it is working in *some* systems?

because:
Clo wrote:—> loth- It works perfectly here, I tested with a board of thumb-nails, no problems !
- Win XP-Pro - XnView 1.82.4
and he uses XPpro like me.

sorry, but i did not understand you quite clearly yet.
loth
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

ONE---

Post by Clo »

:) Hello !

- I never use TWO letters, and with the initial only, that works still OK !

:mrgreen: VG
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Re: moving quickly through folders is not possible anymore?

Post by loth »

xnview wrote:Because the $soft liview control has many problems, so now in thumbnail mode, this doesn't work anymore...
hello pierre,

is this still making trouble? this is one of my deepest whiches for xnview. (browsing/moving through folders with the keyboard)

here, its still a pain to move through a lot of folders which are all start with the same letter,
like

f1
f2
f3
ff1
ff2
ff3
foo1
foo2
foo3
foo4
foa
fob
foc
fo10
fo2
fo3
fo4



with explorer, i just type "foo3" to go to the folder "foo3" and ready.

with xnview, i have to search the folder which is very heady with a lot of folders.
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Re: moving quickly through folders is not possible anymore?

Post by loth »

its a pitty that i'm the only one which uses the keyboard to navigate through my image-folders....

überall nur mausschuber :)
loth wrote:
xnview wrote:Because the $soft liview control has many problems, so now in thumbnail mode, this doesn't work anymore...
hello pierre,

is this still making trouble? this is one of my deepest whiches for xnview. (browsing/moving through folders with the keyboard)

here, its still a pain to move through a lot of folders which are all start with the same letter,
like

f1
f2
f3
ff1
ff2
ff3
foo1
foo2
foo3
foo4
foa
fob
foc
fo10
fo2
fo3
fo4



with explorer, i just type "foo3" to go to the folder "foo3" and ready.

with xnview, i have to search the folder which is very heady with a lot of folders.
pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer »

First: are we talking about the same thing? I have XnView (1.952) under XP SP3, left tree window, right thumbnail window.

I highlight the tree, which shows tons of entries 2003_xxxx up to 2008_xxx. Now I type '2005' and it jumps there. I type '2008' and it jumps there. To me it looks like it works exactly as you want (I did not know because I never used it this way - thanks for showing me).
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

It's a known bug, quite annoying. :(

http://newsgroup.xnview.com/viewtopic.php?t=5000

pic_viewer - are you using Thumbnails or Thumbnails & Labels mode?
Dreamer
pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer »

Dreamer wrote:It's a known bug, quite annoying. :(

http://newsgroup.xnview.com/viewtopic.php?t=5000

pic_viewer - are you using Thumbnails or Thumbnails & Labels mode?
It works in both modes for me under Vista. Under XP I used Thumbnails only.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

Strange. :?
Dreamer
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Post by loth »

thanks to dreamer for pointing out thats its a bug. i didnt know that yet. i thought, it is a feature :-)

pic_viewer wrote:First: are we talking about the same thing? I have XnView (1.952) under XP SP3, left tree window, right thumbnail window.

I highlight the tree, which shows tons of entries 2003_xxxx up to 2008_xxx. Now I type '2005' and it jumps there. I type '2008' and it jumps there. To me it looks like it works exactly as you want (I did not know because I never used it this way - thanks for showing me).
i deleted my xnview.ini (stored in program folder), and started xnview. answered those starting questions when xnview starts the first time, then moved to an image folder and typed some letters to see, that only the first one is used to jump to the according file.

is there a way to turn this "quick search" feature on or off?
i didnt find any related text in the options to experiment with.
if its a bug, it must be reporoduceable, and i'm very interested to have this solved...
pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer »

loth wrote:moved to an image folder and typed some letters to see, that only the first one is used to jump to the according file.
I just verfied in my normal C:\ directory that it does work with letters (not only numbers like tested before). I have no clue why it does not work for you, usually I am the one where something does not work... ;-)
User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Post by loth »

pic_viewer wrote:
loth wrote:moved to an image folder and typed some letters to see, that only the first one is used to jump to the according file.
I just verfied in my normal C:\ directory that it does work with letters (not only numbers like tested before). I have no clue why it does not work for you, usually I am the one where something does not work... ;-)
thanks for checking.
if it is total clear and correct, that you've tried it the way i described here, then there must be something different within our windows XP installations, to what xnview links/refers to.

maybe some kind of DLL which offers standard -anywhat- i don't know.

but if pierre could give a list of DLLs used/refered by xnview, we could compare those (at least the version numbering)

if it is that simple :-)
Post Reply