1.93.4: JPG file crashes image browser

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Myke Greywolf
Posts: 1
Joined: Fri Apr 04, 2008 6:45 pm

1.93.4: JPG file crashes image browser

Postby Myke Greywolf » Fri Apr 04, 2008 6:56 pm

The following image:

Image

When saved locally and shown on XnView's image browser, makes XnView 1.93.4 crash.

It happens on my system, both under Windows XP and Ubuntu 8.04/Wine 0.9.58. Can someone confirm this?
Last edited by Myke Greywolf on Sat Apr 05, 2008 8:34 am, edited 2 times in total.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Nice here

Postby Clo » Fri Apr 04, 2008 9:35 pm

:arrow: Myke Greywolf

:) Hello !

• I cannot confirm, your image saved in my PC works like a charm in 1.93.4, Win XP-Pro SP1

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: 1.93.4: JPG file crashes image browser

Postby oops66 » Fri Apr 04, 2008 10:38 pm

Myke Greywolf wrote:The following image:
Image
When saved locally and shown on XnView's image browser, makes XnView 1.93.4 crash.
It happens on my system, both under Windows XP and Ubuntu/Wine. Can someone confirm this?

Yes, I confirm for Xnview v1.93.4 under Ubuntu 7.10/wine v0.9.58
And also for XnviewMP alpha1 under Ubuntu 7.10
But works perfectly under Xnview Un*x v1.70 under Ubuntu 7.10
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Grzesiek
Posts: 15
Joined: Tue Nov 01, 2005 6:47 pm
Location: Krakow, Poland
Contact:

Postby Grzesiek » Sat Apr 05, 2008 12:42 pm

No crash on 1.93.4 Vista Business 32b PL. But thumbnail for this image is corupted in browser, so I think, embeded EXIF thumbnail is simply broken.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Postby oops66 » Sat Apr 05, 2008 1:00 pm

Grzesiek wrote:No crash on 1.93.4 Vista Business 32b PL. But thumbnail for this image is corupted in browser, so I think, embeded EXIF thumbnail is simply broken.

Yes I think so, this crash is probably due to a corrupted exif thumbnail, but anyway xnview must do not crash under some systems for that .
PS: v1.93.4 Crash under windows98 too.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.93.4: JPG file crashes image browser

Postby xnview » Mon Apr 14, 2008 9:19 am

Ok, the embedded thumbnail seems to have a problem!
Pierre.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: 1.93.4: JPG file crashes image browser

Postby oops66 » Tue Apr 22, 2008 10:54 pm

Clo wrote::arrow: Myke Greywolf
:) Hello !
• I cannot confirm, your image saved in my PC works like a charm in 1.93.4, Win XP-Pro SP1
:mrgreen: KR
Claude
Clo

Hello Clo !
Maybe you do not use in options\Thumbnails\ the "Use Embedded Thumbnails" item ?
Last edited by oops66 on Tue Apr 22, 2008 11:10 pm, edited 2 times in total.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: Nice here

Postby oops66 » Tue Apr 22, 2008 11:07 pm

Solved with XnView v1.93.6 beta2
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

No crash, but broken

Postby Clo » Tue Apr 22, 2008 11:21 pm

:arrow: oops66

:) Hello !

• I USE that option.
- I tested again with the image as alone in a separate folder, I don't get any crash…
- … but the thumb nail itself is broken in all versions I tested with (old 1.82.4, for instance).
- The preview is OK, though.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: No crash, but broken

Postby oops66 » Tue Apr 22, 2008 11:28 pm

Re:
OK, thanks for you information Clo !
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Postby marsh » Wed Apr 23, 2008 6:02 am

I see a better embedded thumbnail with latest test version.
Image

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

"Less worse" ?

Postby Clo » Wed Apr 23, 2008 3:29 pm

:arrow: marsh

:) Hello B. !

• Don't you mean a “less worse” thumb nail ? Image Anyway, nothing to do with the motif…

• I get the same, and also in the “Universal Viewer” (by Alextp) TC (and standalone) tool,
which has very good image display features…
- Obviously, that image has a defect, and I don't think that the real thumb nail could be displayed properly… Image

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: "Less worse" ?

Postby oops66 » Wed Apr 23, 2008 4:27 pm

Clo wrote:... I don't think that the real thumb nail could be displayed properly… Image
...

Hi Clo,
You have just to open it , and save it to rebuld the embedded thumbnail.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Original

Postby Clo » Wed Apr 23, 2008 4:56 pm

:arrow: oops66

:) hello !

• Yes indeed, I meant with the original file…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: Original

Postby oops66 » Wed Apr 23, 2008 5:08 pm

Clo wrote::arrow: oops66
:) hello !
• Yes indeed, I meant with the original file…
:mrgreen: KR
Claude
Clo

Ah OK - oops !
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 0 guests