Feedback on 0.12 using Ubuntu Linux: bugs and suggestions.

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, helmut, xnview

User avatar
Posts: 5
Joined: Mon Mar 02, 2009 2:44 am

Feedback on 0.12 using Ubuntu Linux: bugs and suggestions.

Post by asharpe »

First of all, thank you for making this raw browser and viewer on
Linux. I have tried many, and so far, I like this one the best. For
comparison, all the others had various things wrong with them. All I
wanted to be able to do was browse raw images, preview them, look at
the exif and possibly the histogram, tag some and move them to a
subdirectory to be worked on. I tried gthumb, rawtherapee, digikam,
f-spot, bluemarine, picasa, lightzone and about ten other ones. Either they
couldn't use raw files, or they insisted on moving my photos around,
or they didn't have a filesystem browser, or they didn't tag, or they
crashed, or they were unresponsive to feedback, or various other issues.

So, here's some things I have found. I apologize if these are already
known; I did try to search a bit on the forum before posting.

Version 0.12 (Nov 19 2008)
Libformat version 5.06
Ubuntu Gutsy (7.10)

Drag and drop doesn't work, which is the main feature I need. The
pointer changes to add the + or link arrow (as appropriate to the
modifier key I use), but nothing happens, No copy, no link, no move.

There is no zoom indication in the preview window in browse like there
is in view mode (I'm calling view mode what you get when you double
click on a photo).

Show info in view mode is fairly useless; exif would be nice to see in
addition to the filename (which is actually redundant, except for the

The zoom slider in view mode is *very* sensitive, and too short; you
could make the slider longer, so it takes longer to go from 7% to
1600%. On my screen, the slider is only about .75 of an inch long.

In the browser preview mode, when the picture is zoomed, the right
button brings up a large menu, but when the button is released, I get
the grab icon, and the preview is stuck in grab mode until I
click. And since the grab only works until the cursor hits the edges
of the preview window, it isn't too useful. I know that the right
buttom moves around the image in large view mode, so it looks like the
button function is overloaded in preview more. Using a space to change
to grab in both modes might be better.

Refresh in the folder view pane doesn't see new folders when they
appear (doesn't reread the directory). Even expanding and contracting
a folder doesn't appear to reread the directory. That's fine, as long
as the refresh worked.

Again, thanks for a great program, and I hope these issues are
considered, or have already been considered, for a new version.

User avatar
Posts: 5
Joined: Mon Mar 02, 2009 2:44 am

Post by asharpe »

Out of all these issues, the drag and drop to move photos around is the one that bothers me the most. Does everyone have the same problem in Linux? I tried XnView on Ubuntu Hardy (8.04.2) as well, and the drag and drop doesn't work there, either. Can anyone confirm that it works in any Linux? Or, is this simply a known limitation with 0.12 on Linux?
User avatar
Posts: 2005
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Post by oops66 »

asharpe wrote:... Or, is this simply a known limitation with 0.12 on Linux?
I have the same problem with the MP v0.12 (linux and windows+wine), so I guess than it is a know limitation with MP v0.12 (due to the alpha MP stage).
XnViewMP Linux X64 - Debian - X64