REQ: Media file preview

Ideas for improvements and requests for new features in XnView Classic

Moderators: XnTriq, xnview

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

REQ: Media file preview

Post by Danny » Wed May 18, 2005 10:08 pm

In reference to this old thread i first have to say: thanks a million for fixing the issues i brought up regarding the media preview (muting and volume control). But there are still two things i like to suggest:

1. It would be nice to have a setting to disable auto-playing of media files.
2. If you disable previewing media files, it would be great if there was still a freeze image of the video being shown without the movie controls in the preview area.

The 2nd point isn't really neccessary though once you've already created the 1st option.

Greets
Danny

P.S.: Thanks again for listening to given input.

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Media file preview

Post by xnview » Thu May 19, 2005 1:06 pm

Danny wrote:In reference to this old thread i first have to say: thanks a million for fixing the issues i brought up regarding the media preview (muting and volume control). But there are still two things i like to suggest:

1. It would be nice to have a setting to disable auto-playing of media files.
2. If you disable previewing media files, it would be great if there was still a freeze image of the video being shown without the movie controls in the preview area.

The 2nd point isn't really neccessary though once you've already created the 1st option.
You have Options/Browser/Preview/Play movie
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Re: REQ: Media file preview

Post by Danny » Thu May 19, 2005 2:30 pm

xnview wrote:
Danny wrote:In reference to this old thread i first have to say: thanks a million for fixing the issues i brought up regarding the media preview (muting and volume control). But there are still two things i like to suggest:

1. It would be nice to have a setting to disable auto-playing of media files.
2. If you disable previewing media files, it would be great if there was still a freeze image of the video being shown without the movie controls in the preview area.

The 2nd point isn't really neccessary though once you've already created the 1st option.
You have Options/Browser/Preview/Play movie
Yes, but that disables the preview completely. I just want it to not start the playback automatically. I attached a picture to clearify myself:
Image

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Media file preview

Post by xnview » Thu May 19, 2005 3:19 pm

Danny wrote:
xnview wrote:
Danny wrote:In reference to this old thread i first have to say: thanks a million for fixing the issues i brought up regarding the media preview (muting and volume control). But there are still two things i like to suggest:

1. It would be nice to have a setting to disable auto-playing of media files.
2. If you disable previewing media files, it would be great if there was still a freeze image of the video being shown without the movie controls in the preview area.

The 2nd point isn't really neccessary though once you've already created the 1st option.
You have Options/Browser/Preview/Play movie
Yes, but that disables the preview completely. I just want it to not start the playback automatically. I attached a picture to clearify myself:
Image
If play movie is not active, you must have a preview for it.
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Re: REQ: Media file preview

Post by Danny » Thu May 19, 2005 3:43 pm

xnview wrote:If play movie is not active, you must have a preview for it.
I don't understand what you mean. :?:

I meant, if "autoplay" is off, then it would show a freeze image (the first frame for example) of the video. Like in the thumbnail view but in bigger size (to fit into the preview area). If with movie controls or without doesn't really matter to me.

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Media file preview

Post by xnview » Thu May 19, 2005 3:47 pm

Danny wrote:
xnview wrote:If play movie is not active, you must have a preview for it.
I don't understand what you mean. :?:

I meant, if "autoplay" is off, then it would show a freeze image (the first frame for example) of the video. Like in the thumbnail view but in bigger size (to fit into the preview area). If with movie controls or without doesn't really matter to me.
Yes, you have it already. If "Play movie" is not set, you have the first frame of movie.
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Re: REQ: Media file preview

Post by Danny » Thu May 19, 2005 3:50 pm

xnview wrote:
Danny wrote:
xnview wrote:If play movie is not active, you must have a preview for it.
I don't understand what you mean. :?:

I meant, if "autoplay" is off, then it would show a freeze image (the first frame for example) of the video. Like in the thumbnail view but in bigger size (to fit into the preview area). If with movie controls or without doesn't really matter to me.
Yes, you have it already. If "Play movie" is not set, you have the first frame of movie.
No. Not over here. If i disable "Play movie" in the browsers preview options i get no preview at all. :(

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Media file preview

Post by xnview » Thu May 19, 2005 4:29 pm

Danny wrote:No. Not over here. If i disable "Play movie" in the browsers preview options i get no preview at all. :(
On which type of movie? MPG? AVI? MOV?
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Re: REQ: Media file preview

Post by Danny » Thu May 19, 2005 4:40 pm

xnview wrote:
Danny wrote:No. Not over here. If i disable "Play movie" in the browsers preview options i get no preview at all. :(
On which type of movie? MPG? AVI? MOV?
Any type of video. Do you want my .ini?

Can't someone else confirm this?

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Media file preview

Post by xnview » Thu May 19, 2005 4:42 pm

Danny wrote:
xnview wrote:
Danny wrote:No. Not over here. If i disable "Play movie" in the browsers preview options i get no preview at all. :(
On which type of movie? MPG? AVI? MOV?
Any type of video. Do you want my .ini?

Can't someone else confirm this?
You must have preview for AVI & MPEG files
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Thu May 19, 2005 4:49 pm

Pierre,

I guess it's misunderstanding, I think you mean "thumbnail preview" and Danny means "preview in preview area".

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu May 19, 2005 7:02 pm

Dreamer wrote:I guess it's misunderstanding, I think you mean "thumbnail preview" and Danny means "preview in preview area".
No, i means preview of movie in preview are. ;-)
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny » Thu May 19, 2005 7:20 pm

xnview wrote:
Dreamer wrote:I guess it's misunderstanding, I think you mean "thumbnail preview" and Danny means "preview in preview area".
No, i means preview of movie in preview are. ;-)
Ok. Then we are talking about the same thing. And as i said - i don't get any preview. Here's my ini just in case: xnview.ini

User avatar
xnview
Author of XnView
Posts: 32082
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu May 19, 2005 7:23 pm

Danny wrote:
xnview wrote:
Dreamer wrote:I guess it's misunderstanding, I think you mean "thumbnail preview" and Danny means "preview in preview area".
No, i means preview of movie in preview are. ;-)
Ok. Then we are talking about the same thing. And as i said - i don't get any preview. Here's my ini just in case: xnview.ini
Ok, please try with RC2, i remember that i have changed something.
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny » Thu May 19, 2005 7:31 pm

xnview wrote:Ok, please try with RC2, i remember that i have changed something.
I will. Thanks!

Post Reply