IPTC keyword iso8859-15 and UTF-8

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
caesarvic
Posts: 10
Joined: Mon Mar 28, 2011 8:14 pm
Location: France

IPTC keyword iso8859-15 and UTF-8

Post by caesarvic »

Hello,
I start with XnView MP 0.35 fro unix on Ubuntu (intrepid).
I have the following problem:
If i open an existing jpg picture with keywords encoded in Iso8859-1 ( or iso8859-15 or latin1 ) all keywords with accented french characters are displayed in the right way ( " é " " à " ).
But if I add a new keyword (even an english one!) a character such as " é " ( existing in a previous keyword) is translated into "éééé" (whose hexa value is x"c3a9c3a9c3a9c3a9").
Actually , all keywords are written back with UTF-8 encoding.
Of course in the " tools setting metadata " parameter and " IPTC encoding " tab i have choosen " default IPTC encoding " iso8859-1 and " don't use UTF-8 to write IPTC fields " .
Could anyone tell me if he observes the same behaviour ?
Or could anyone give me some suggestion to correct the problem ?
I don't observe the problem with XnView MP for windows !
Thanks.
carnussien
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC keyword iso8859-15 and UTF-8

Post by xnview »

And if you use 'locale'??
Could you send me a sample file?
Pierre.
caesarvic
Posts: 10
Joined: Mon Mar 28, 2011 8:14 pm
Location: France

Re: IPTC keyword iso8859-15 and UTF-8

Post by caesarvic »

hello xnview
I send you 2 files .
The first one named "testkwAvant.jpg was created with XnViewMP for windows.
I added the IPTC keyword 'ééééééééééééééé' whose pattern is easily found in an hexa editor.
That keyword in encoded in latin1 (iso8859-15 or -1).

The second one named "testkwAprès.jpg" is just a copy of the first one.
But with XnViewMP for unix, I added the IPTC keyword "newkeyword".
You can see that both keywords are encoded in UTF-8. It's my problem!

Of course in both cases the settings are don't ask to "Use UTF-8 to write IPTC fields"

About "locale" : I know that it is a "touchy" system wide area.
So I would prefer to leave them as they are (UTF-8 and french).
Thanks for your help.
Attachments
testkwAprès.jpg
testkwAprès.jpg (35.81 KiB) Viewed 1248 times
testkwAvant.jpg
testkwAvant.jpg (35.61 KiB) Viewed 1248 times
carnussien
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC keyword iso8859-15 and UTF-8

Post by xnview »

Oh ok, so no problem on Windows, only on linux, right?
Pierre.
caesarvic
Posts: 10
Joined: Mon Mar 28, 2011 8:14 pm
Location: France

Re: IPTC keyword iso8859-15 and UTF-8

Post by caesarvic »

Right !
carnussien
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC keyword iso8859-15 and UTF-8

Post by xnview »

caesarvic wrote:Right !
Ok, i understand now (i test on current version not 0.35), i've fixed it. Send your email by PM if you want a test version?
Pierre.
caesarvic
Posts: 10
Joined: Mon Mar 28, 2011 8:14 pm
Location: France

Re: IPTC keyword iso8859-15 and UTF-8

Post by caesarvic »

Hello pierre,
OK i sent you my email address
Thanks
carnussien
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC keyword iso8859-15 and UTF-8

Post by xnview »

caesarvic wrote:Hello pierre,
OK i sent you my email address
Thanks
Do you have received my mail?
Pierre.
caesarvic
Posts: 10
Joined: Mon Mar 28, 2011 8:14 pm
Location: France

Re: IPTC keyword iso8859-15 and UTF-8

Post by caesarvic »

xnview wrote:
caesarvic wrote:Hello pierre,
OK i sent you my email address
Thanks
Do you have received my mail?
No, not yet.
carnussien
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC keyword iso8859-15 and UTF-8

Post by xnview »

caesarvic wrote:
xnview wrote:
caesarvic wrote:Hello pierre,
OK i sent you my email address
Thanks
Do you have received my mail?
No, not yet.
Resent...
Pierre.
Post Reply