EXIF problem for Olympus E-300 jpgs

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
ardklg
Posts: 4
Joined: Tue Oct 17, 2006 1:59 pm

EXIF problem for Olympus E-300 jpgs

Post by ardklg »

The Batch Rename is unable to correctly pull some of the EXIF information from Olympus E-300 jpg files. It correctly gets the EXIF-CAMERA info, but not the EXIF-IMAGE info (such as date taken). When viewing the properties for the image, the EXIF IMAGE info is listed correctly - it just isn't accessed by the batch rename function.

Everything works fine for my other files (C-8080, E-500, etc.), but not the E-300 files.

This is true for stable as well as alpha.

Thanks for your attention.
User avatar
xnview
Author of XnView
Posts: 33916
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: EXIF problem for Olympus E-300 jpgs

Post by xnview »

ardklg wrote:The Batch Rename is unable to correctly pull some of the EXIF information from Olympus E-300 jpg files. It correctly gets the EXIF-CAMERA info, but not the EXIF-IMAGE info (such as date taken). When viewing the properties for the image, the EXIF IMAGE info is listed correctly - it just isn't accessed by the batch rename function.

Everything works fine for my other files (C-8080, E-500, etc.), but not the E-300 files.

This is true for stable as well as alpha.

Thanks for your attention.
Could you send me a sample, please?
Pierre.
ardklg
Posts: 4
Joined: Tue Oct 17, 2006 1:59 pm

Post by ardklg »

Done.

Thanks for taking a look.
User avatar
B.Douille
Posts: 198
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

EXIF data (dates) not managed correctly

Post by B.Douille »

I've got a similar issue since I use some photophones.
With my usual camera, in the EXIF data the date and time figures are separated with a space.
With Sharp and Sony-Ericsson models the date and time are recorded using columns only, like this:
2006:06:30:17:52:26
It's all the same for date modified, date taken and date digitized.

Using a template as "Date Digitized [Y-m-d_HMS]", the batch rename tool would rename the file as bellow:
3906-07-30_000000.jpg

regards
User avatar
B.Douille
Posts: 198
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Batch Rename is unable to correctly pull dates from EXIF

Post by B.Douille »

I tested in Beta 3 and the result is the same.
It looks like the batch rename feature uses the columns to identify date, month, hour, minute,... and so is lost when extracting the date/time from EXIF data.
The property pane in v1.90 reports the dates and time correctly, with the columns visible (raw display I guess)

Do you want a sample from a photophone too ?

Regards
User avatar
xnview
Author of XnView
Posts: 33916
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Batch Rename is unable to correctly pull dates from EXIF

Post by xnview »

B.Douille wrote:I tested in Beta 3 and the result is the same.
It looks like the batch rename feature uses the columns to identify date, month, hour, minute,... and so is lost when extracting the date/time from EXIF data.
The property pane in v1.90 reports the dates and time correctly, with the columns visible (raw display I guess)

Do you want a sample from a photophone too ?
Yes please
Pierre.
Post Reply