Browser tree expansion

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
paulba
Posts: 15
Joined: Sat Apr 29, 2006 6:43 am

Browser tree expansion

Post by paulba » Thu Dec 14, 2006 10:15 am

This is hard to explain in text....

when browsing through folders each folder can be expanded by selecting the "+", if there are no more sub folder then there is no "+".

This is correct for local drives but network drives always have a "+" on the folder even when there is no more sub folders.

examples

Local drive ...Image

Network drive ... Image

if there are no sub folders then there should be no indication that there is. At worst the "+" should disappear when the folder is selected and the browser finds there is no more sub folders.

This happens in versions 1.82.4 and 1.90 beta 3.

Thanks
Last edited by paulba on Tue Jul 26, 2011 6:23 am, edited 1 time in total.

ckit
XnThusiast
Posts: 2439
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Thu Dec 14, 2006 10:20 am

What you are asking might make XnView even slower with UNC paths or mapped drives.
XnView's tree handling should remain the same as Windows Explorer's.
Windows 10 Pro x64 1809, Malwarebytes Premium, Process Lasso Pro
XnView Classic, Paint.NET and PhotoFiltre Studio X

paulba
Posts: 15
Joined: Sat Apr 29, 2006 6:43 am

Post by paulba » Thu Dec 14, 2006 8:14 pm

XnView's tree handling should remain the same as Windows Explorer's.
That would mean it worked the same for both local and network drives. Xnview currently does not match windows explorer.

paulba
Posts: 15
Joined: Sat Apr 29, 2006 6:43 am

Post by paulba » Sat Jun 07, 2008 2:58 am

This is still an annoying glitch ..

examples

Windows Explorer... Image

Xnview Browser... Image

if there are no sub folders then there should be no indication that there is.

is there a chance this will ever be fixed??

Regards,

Paul
Last edited by paulba on Tue Jul 26, 2011 6:23 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 30875
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sun Jun 08, 2008 2:58 pm

paulba wrote: if there are no sub folders then there should be no indication that there is.

is there a chance this will ever be fixed??
Yes, on network i don't check for subfolder, take often long long time
Pierre.

paulba
Posts: 15
Joined: Sat Apr 29, 2006 6:43 am

Post by paulba » Mon Jun 09, 2008 6:49 am

Yes, on network i don't check for subfolder, take often long long time
??

1. Yes this will be changed

2. it wont change due to time??

If 2 the please add an option in ini file to let us make the decision based on our environment.

Thanks

Paul

User avatar
xnview
Author of XnView
Posts: 30875
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Jun 09, 2008 1:26 pm

Ok, i'll add an ini entry for next release
Pierre.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Mon Feb 09, 2009 1:40 pm

CheckNetFolder doesn't seem to work in 1.95.4 and 1.96 beta. :(

User avatar
xnview
Author of XnView
Posts: 30875
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Feb 10, 2009 7:45 am

ckv wrote:CheckNetFolder doesn't seem to work in 1.95.4 and 1.96 beta. :(
Yes, CheckNetFolder is no more used since 1.94.2
You have a '+' when no subfolder??
Pierre.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Tue Feb 10, 2009 3:13 pm

xnview wrote:
ckv wrote:CheckNetFolder doesn't seem to work in 1.95.4 and 1.96 beta. :(
Yes, CheckNetFolder is no more used since 1.94.2
You have a '+' when no subfolder??
Yes, I always have '+' for network folders on Windows 2000 SP4.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Browser tree expansion

Post by ckv » Fri Mar 20, 2009 1:48 pm

XnView 1.96 changelog wrote:Fixed:
* CheckNetFolder entry - http://newsgroup.xnview.com/viewtopic.php?t=11011
I didn't realize that this was fixed for XnView 1.96 until now. But when I use CheckNetFolder in XnView 1.96 I don't get the '+' on any folder and the folder tree is unusable?? :(
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

Post Reply