[Minor] “Next file” button not greyed…

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

[Minor] “Next file” button not greyed…

Post by Clo »

:) Hello !

• Open any folder containing some images in the browser

• Preview any one

• Display it in View (2-click, Enter or so), press the “Next file” button n… times up to the end (or the End key).
- When the last file is displayed, the button is not greyed as it should.

- If you open the same file directly in View, then the button is greyed when the last file comes.
- "Loop" is disabled, of course.

:mrgreen:
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 37624
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [Minor] “Next file” button not greyed…

Post by xnview »

Clo wrote::) Hello !

• Open any folder containing some images in the browser

• Preview any one

• Display it in View (2-click, Enter or so), press the “Next file” button n… times up to the end (or the End key).
- When the last file is displayed, the button is not greyed as it should.

- If you open the same file directly in View, then the button is greyed when the last file comes.
- "Loop" is disabled, of course.

:mrgreen:
Can't reproduce, the next button is greyed when i press 'End'
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

From browser

Post by Clo »

:) Hello Pierre!

• This occurs ONLY when the image in VIEW comes from the browser, did you test like this ?
- Here, I can reproduce it by 100% !
VIDEO

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique

Post by ouistiti »

:arrow: Pierre

I can reproduce the Clo's bug, but only when the display is set "By extension".

The bug doesn't occur when the display is set "By name".

Friendly

Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Yep !

Post by Clo »

—> ouistiti

:) Hello Paul !

• Yep ! Right ! Thank you to point out that condition I missed…

• In fact, I sort the most times like this, in order to match the TC same sorting I use always…

:mrgreen: Friendly,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 37624
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

ouistiti wrote::arrow: Pierre

I can reproduce the Clo's bug, but only when the display is set "By extension".

The bug doesn't occur when the display is set "By name".
You have not a not viewable file?? If i use a folder with only file picture, i have not the problem
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

3 icons !

Post by Clo »

:arrow: Pierre

:) Hello !

• The video you can see is made from a folder containing only three icons…
- So, not any crappy file!

- Like Paul points out, you must set the sorting by extension to reproduce the hitch…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 37624
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 3 icons !

Post by xnview »

Clo wrote::arrow: Pierre

:) Hello !

• The video you can see is made from a folder containing only three icons…
- So, not any crappy file!

- Like Paul points out, you must set the sorting by extension to reproduce the hitch…
If i have only 3 picture, and sort by ext, i can't reproduce it
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

XP-SP1

Post by Clo »

:) Either you didn't test under XP, or you have a blessed PC, or both ! :D

• XP-Pro SP1 here, and SP2 @ Paul's…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

OK…

Post by Clo »

:) Hi !

• Seems fixed in 1.90.2

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Gone and back…

Post by Clo »

—> Pierre

:) Hello !

• That bug is back in the 1.91.5, exactly like explained above in the same conditions…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice