1.91.6: Canon 40D RAW Support - FIXED

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, helmut, xnview

visceralpsyche
Posts: 3
Joined: Sun Oct 07, 2007 4:31 pm
Location: Netherlands

1.91.6: Canon 40D RAW Support - FIXED

Post by visceralpsyche »

I recently bought the new Canon 40D camera and noticed that the RAW support as of 1.91.5 seems buggy:

Image

It puts a weird pink overlay on each image but does show the image itself underneath.

I figure since the camera is new you may not have access to a RAW image from the camera yet, so I have uploaded one for you so you can use it to perhaps pull out the embedded JPG or otherwise figure out how to view them correctly (10MB RAW CR2 image):

http://www.visceralpsyche.com/misc/web_ ... G_0001.CR2

Thanks for all your work!

Paul
Last edited by visceralpsyche on Sat Dec 22, 2007 7:22 am, edited 2 times in total.
User avatar
xnview
Author of XnView
Posts: 39834
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.91.5 - Canon 40D RAW Support

Post by xnview »

visceralpsyche wrote:I recently bought the new Canon 40D camera and noticed that the RAW support as of 1.91.5 seems buggy:
Ok, 'ill check
Pierre.
visceralpsyche
Posts: 3
Joined: Sun Oct 07, 2007 4:31 pm
Location: Netherlands

Post by visceralpsyche »

Thanks for the 1.91.6 version but this bug still remains. Just bumping it with the new version number in the thread title.

Cheers,

Paul
ckit
XnThusiast
Posts: 2540
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

I just tried this image and I get the same pink result.
I'm willing to bet it has something to do with "Component Configuration = YCbCr"
AMD Ryzen 3 3300X 3.8Ghz, 16Gb DDR4, RX 6600XT with Dell U2520D at 2560x1440@60Hz
PhotoFiltre 11, Vivaldi Browser 5.7, Windows 11 Pro x64 22H2 + Snipping Tool, XnViewMP 1.4.3 and XYplorer
User avatar
oops66
XnThusiast
Posts: 2005
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Post by oops66 »

I just tried this image too (IMG_0001.CR2 - 10 530 ko ), and for me all is OK, I do not have this pink result.
Strange!
XnViewMP Linux X64 - Debian - X64
ckit
XnThusiast
Posts: 2540
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

IrfanView 4.10 works great!
PhotoFiltre Studio 9.0.0 produces a green effect!

Use IrfanView until we have proper support for 48-bit images.
AMD Ryzen 3 3300X 3.8Ghz, 16Gb DDR4, RX 6600XT with Dell U2520D at 2560x1440@60Hz
PhotoFiltre 11, Vivaldi Browser 5.7, Windows 11 Pro x64 22H2 + Snipping Tool, XnViewMP 1.4.3 and XYplorer
ckit
XnThusiast
Posts: 2540
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

oops66, can you post screenshots of your "Camera Raw" and "RAW" settings in Read\Write dialog box?

ACDSee 10 doesn't support this format yet but the developers on the forum say they are working on it.
VSO Image Resizer was updated recently too to support it.

I'm trying to get PhotoFiltre Studio's author to look at it too.
AMD Ryzen 3 3300X 3.8Ghz, 16Gb DDR4, RX 6600XT with Dell U2520D at 2560x1440@60Hz
PhotoFiltre 11, Vivaldi Browser 5.7, Windows 11 Pro x64 22H2 + Snipping Tool, XnViewMP 1.4.3 and XYplorer
User avatar
oops66
XnThusiast
Posts: 2005
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Post by oops66 »

ckit wrote:oops66, can you post screenshots of your "Camera Raw" and "RAW" settings in Read\Write dialog box?
...
Hello,
Here it is some information :
Screenshot of this .cr2 file:
IMG_0001.CR2 - 10 530 ko , without your pink result.
(without the Jpeg compression bellow, the background is perfectly gray)
Image
config. options RAW:
Image
Image
Image
Regards,
Oops66
XnViewMP Linux X64 - Debian - X64
ckit
XnThusiast
Posts: 2540
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

Ok, given it works on Win98SE it must be a OS related bug with XnView.
AMD Ryzen 3 3300X 3.8Ghz, 16Gb DDR4, RX 6600XT with Dell U2520D at 2560x1440@60Hz
PhotoFiltre 11, Vivaldi Browser 5.7, Windows 11 Pro x64 22H2 + Snipping Tool, XnViewMP 1.4.3 and XYplorer
s_boy70

Canon EOS400D

Post by s_boy70 »

info: I've got the same pink effect with canon EOS 400D raw pics (.cr2) under Windows XP SP1.
pasta

1.91.6: Canon 40D RAW Support

Post by pasta »

just to let you know. I have the same result. (XP SP2)
visceralpsyche
Posts: 3
Joined: Sun Oct 07, 2007 4:31 pm
Location: Netherlands

Post by visceralpsyche »

Fixed in 1.92 - thankyou!

Have a Merry Xmas and Happy New Year :)

Paul