Wrong filelist background color

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Wrong filelist background color

Postby Danny » Sat Jan 26, 2008 10:09 pm

IIRC the unknown files in the filelist used to have a white background color. Now all folders and all unknown files have a gray background here, if i switch on "use color based on fileformat".

The browser -> filelist -> misc -> background color option only works for the background of the icons.

How come? I want my white back.
Last edited by Danny on Sun Feb 24, 2008 7:02 pm, edited 1 time in total.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Wrong filelist background color

Postby xnview » Sun Jan 27, 2008 7:44 pm

Danny wrote:IIRC the unknown files in the filelist used to have a white background color. Now all unknown files have a gray background here, if i switch on "use color based on fileformat".

The browser -> filelist -> misc -> background color option only works for the background of the icons.

How come? I want my white back.

In thumbnail mode?
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Mon Jan 28, 2008 6:34 pm

No, in every mode really. Folders and files. That particular setting is for the details view.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Jan 28, 2008 7:06 pm

Danny wrote:No, in every mode really. Folders and files. That particular setting is for the details view.

Do you have changed the text back color inOption/Thumb/Labels?
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Mon Jan 28, 2008 8:52 pm

xnview wrote:
Danny wrote:No, in every mode really. Folders and files. That particular setting is for the details view.

Do you have changed the text back color inOption/Thumb/Labels?

Yes, but i can change the settings all i want, it's always the same gray background color. The text color does react though.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Tue Jan 29, 2008 6:59 am

Danny wrote:
xnview wrote:
Danny wrote:No, in every mode really. Folders and files. That particular setting is for the details view.

Do you have changed the text back color inOption/Thumb/Labels?

Yes, but i can change the settings all i want, it's always the same gray background color. The text color does react though.

Do you have tried with a clean .ini?
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Tue Jan 29, 2008 2:51 pm

xnview wrote:Do you have tried with a clean .ini?

Yes, it's the same.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Sun Feb 24, 2008 7:01 pm

So? What is it? Any news on this? My background is still gray all the time.

If this is not my fault, can someone move this into the bugs forum? Thanks.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Feb 25, 2008 6:53 am

Danny wrote:So? What is it? Any news on this? My background is still gray all the time.

If this is not my fault, can someone move this into the bugs forum? Thanks.

Will be fixed in 1.92.2
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Mon Feb 25, 2008 7:34 am

xnview wrote:Will be fixed in 1.92.2

Excellent. Thanks.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Wed Feb 27, 2008 4:10 pm

Just checked out 1.93.

1. It's unexpected that the thumbnail label text background has an effect on the the ordinary filelist as well.

2. Browser -> filelist ->misc -> background color has no effect whatsoever.

I would expect to find the filelists text background color at the latter position.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Wed Feb 27, 2008 4:11 pm

Danny wrote:Just checked out 1.93.

1. It's unexpected that the thumbnail label text background has an effect on the the ordinary filelist as well.

2. Browser -> filelist ->misc -> background color has no effect whatsoever.

I would expect to find the filelists text background color at the latter position.

Sorry could you show the problem on a screenshot?
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Wed Feb 27, 2008 4:38 pm

Image Image
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.

User avatar
xnview
Author of XnView
Posts: 28559
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Wed Feb 27, 2008 7:19 pm

[quote="Danny"][/quote]
I have not fixed this bug :-) For beta 2
Pierre.

Danny
Posts: 551
Joined: Sat Sep 04, 2004 5:09 pm

Postby Danny » Thu Mar 06, 2008 1:02 pm

Fixed in beta 2.
Get the bugs fixed, THEN start adding features. It sucks, but someone has to do it.


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest