1.92.1 crashes when recreating EXIF thumbnails

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

Post Reply
andrea.ippo
Posts: 100
Joined: Sat Jan 05, 2008 2:05 pm

1.92.1 crashes when recreating EXIF thumbnails

Post by andrea.ippo » Fri Feb 01, 2008 11:41 am

but not when rotating 90° degrees left or right.

Some crash info:

AppName: xnview.exe AppVer: 1.92.0.0 ModName: xnview.exe
ModVer: 1.92.0.0 Offset: 00007b2a

appcompat:
http://www.megaupload.com/it/?d=VZYBHNAN [98.38 KB]

PS: using win xp pro+sp2

User avatar
xnview
Author of XnView
Posts: 29600
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.92.1 crashes when recreating EXIF thumbnails

Post by xnview » Fri Feb 01, 2008 2:24 pm

andrea.ippo wrote:but not when rotating 90° degrees left or right.

Some crash info:

AppName: xnview.exe AppVer: 1.92.0.0 ModName: xnview.exe
ModVer: 1.92.0.0 Offset: 00007b2a

appcompat:
http://www.megaupload.com/it/?d=VZYBHNAN [98.38 KB]

PS: using win xp pro+sp2
Could you send me the file that you use?
Pierre.

andrea.ippo
Posts: 100
Joined: Sat Jan 05, 2008 2:05 pm

Post by andrea.ippo » Fri Feb 01, 2008 2:39 pm

Here it is:
http://www.megaupload.com/it/?d=JZ361SJB
However, it's not the only one that makes xnview crash.
It happens with every photo I've tried, so I don't think this is the matter.
I've even tried using a newly downloaded zip package of the latest version, and even without applying my preferences (i.e: default configuration), the crash remains.

Thank you

andrea.ippo
Posts: 100
Joined: Sat Jan 05, 2008 2:05 pm

Post by andrea.ippo » Sun Feb 03, 2008 5:39 pm

Are there any news?
I've re-uploaded the file on imageshack:
Image

As I said before, however, I don't think this specific file is the problem, because the application crashes even with all other jpegs with EXIF data I've tested...
Thank you

User avatar
helmut
Posts: 8134
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Sun Feb 03, 2008 5:59 pm

Crash confirmed.

When applying "Edit > Metadata > Recreate EXIF thumbnail" on the image provided via MegaUpload XnView crashes with a GPF. :bugconfirmed:

andrea.ippo
Posts: 100
Joined: Sat Jan 05, 2008 2:05 pm

Post by andrea.ippo » Sun Feb 03, 2008 6:06 pm

Thanks for confirming (btw, the image uploaded to megaupload is the same one I've uploaded to imageshack).

Have you had this crash with your photos also, or only with mine?
Thanks

User avatar
helmut
Posts: 8134
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Sun Feb 03, 2008 6:13 pm

andrea.ippo wrote:... Have you had this crash with your photos also, or only with mine?
Eehem - I've tried with several JPG files and it crashed on EVERY JPG file. Until now I haven't found any JPG file without crash. :-|

andrea.ippo
Posts: 100
Joined: Sat Jan 05, 2008 2:05 pm

Post by andrea.ippo » Sun Feb 03, 2008 7:52 pm

helmut wrote:
andrea.ippo wrote:... Have you had this crash with your photos also, or only with mine?
Eehem - I've tried with several JPG files and it crashed on EVERY JPG file. Until now I haven't found any JPG file without crash. :-|
We're in the same situation.

User avatar
helmut
Posts: 8134
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Sun Feb 03, 2008 8:58 pm

andrea.ippo wrote:We're in the same situation.
:-|

This is an easy-to-reproduce and general problem, so it shouldn't take many more versions & time to fix it...

User avatar
xnview
Author of XnView
Posts: 29600
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Feb 05, 2008 9:54 am

Ok, will be fixed in a 1.92.2
Pierre.

User avatar
helmut
Posts: 8134
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Feb 05, 2008 5:57 pm

xnview wrote:Ok, will be fixed in a 1.92.2
It's not nice to have a feature in the program that does not work at all, so it's very good that this will be fixed, soon. :-)

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Thu Mar 13, 2008 11:55 pm

andrea.ippo wrote:
helmut wrote:
andrea.ippo wrote:... Have you had this crash with your photos also, or only with mine?
Eehem - I've tried with several JPG files and it crashed on EVERY JPG file. Until now I haven't found any JPG file without crash. :-|
We're in the same situation.
Fixed. v.1.93

Post Reply