Error message missing

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Error message missing

Post by pic_viewer » Sat Feb 02, 2008 8:26 am

Hello,

I tried to open a jpg file by hitting enter in the TC. Usually XnView starts in viewer mode and shows the file. This time XnView started the browser with the last used directory. I wasted about 15 minutes until I finally discovered that the file had been invalid - size 0 Byte.

Please add an error message dialog when trying to display files where this process fails.

User avatar
xnview
Author of XnView
Posts: 29600
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Error message missing

Post by xnview » Sat Feb 02, 2008 9:14 am

pic_viewer wrote:Hello,

I tried to open a jpg file by hitting enter in the TC. Usually XnView starts in viewer mode and shows the file. This time XnView started the browser with the last used directory. I wasted about 15 minutes until I finally discovered that the file had been invalid - size 0 Byte.

Please add an error message dialog when trying to display files where this process fails.
If you try to open it directly in xnview, do you have the error dialog?
Pierre.

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Sat Feb 02, 2008 10:15 am

Start Viewer, Open, file: Error message 'Error when opening the file xxxx.jpg:

Start browser, navigate to 0 Byte file: no preview. F11 not work. Enter or doubeclick on this file just resets the browser mini-pic view. So no error message in browser no matter what you do.

User avatar
xnview
Author of XnView
Posts: 29600
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Feb 18, 2008 1:50 pm

pic_viewer wrote:Start Viewer, Open, file: Error message 'Error when opening the file xxxx.jpg:

Start browser, navigate to 0 Byte file: no preview. F11 not work. Enter or doubeclick on this file just resets the browser mini-pic view. So no error message in browser no matter what you do.
Strange, i have "Error when opening the file xxxx" if i use enter, double-clic or menu/open
Pierre.

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Sun Feb 24, 2008 7:14 am

Pierre, I am sorry, but I am not able to send personal mails via this forum to you. Whatever I do I get the mail sent to myself. Part of the problem may be that it is all in french, but on the other hand it simply should work when I click on someones name and the option to send him a PM. It does not.

So if you want a sample file showing the error on two different machines then please send me a valid email adress where I can send it to.

Post Reply