Some PNGs 32 BPP shown as 24BPP…

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Some PNGs 32 BPP shown as 24BPP…

Post by Clo » Sun Aug 10, 2008 10:54 pm

:arrow: Pierre

• All PNGs 32 BPP like the image below

ImageImage

are shown in XnView 1.94.2 and older (down to 1.82.4) as 24 BPP with a white BG, while other softs announce 32 BPP alright, also the XnViewShellExt in its thumbnail and the XnView MP, version A 00015.
- The very old 1.80.3 shows 32 BPP, though, also the 1.90 Alpha2. :?

• These images are made and used in GFIE icon editor, where they work perfectly as (boards of) icons…
…and in that soft, only 32 BPP PNGs can work for that purpose !
Note : The image above is a customized one I drew, but the same issue occurs with the original one…

Image Any clue ?

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Some PNGs 32 BPP shown as 24BPP…

Post by xnview » Mon Aug 11, 2008 8:23 am

This png is loaded in 32bits, perhaps you have enabled option/read/png/compose...?
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Ticked, but---

Post by Clo » Mon Aug 11, 2008 3:22 pm

:arrow: Pierre

:) Good afternoon,

• OK, I found the two “Compose…” boxes ticked, but I did not tick them myself… :?

- Then the status-bar displays 32 BPP alright.
- However, I don't understand why it shows “24 BPP” with these options ON,
the image itself is the same, and it's 32 BPP still…

- I had¦have “Use Alpha channel” ON in the View menu, and no problem before.
BTW : Are these “Compose…” options still useful ?

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Post Reply