Can't switch to previous image in slideshow sometimes

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Can't switch to previous image in slideshow sometimes

Post by Dreamer » Thu Aug 28, 2008 11:35 pm

Sometimes when I switch images quickly in the slideshow using the mouse wheel, I can't switch to previous image. I can switch to next image (4) and next (5), then back to 4, 3, but then I can't switch to previous (3) - can't go before #3.

Edit: Perhaps it's pause, I'm using Pause to stop the slideshow, then, after some time it's impossible to go back. It happened few times in 30 min., but I can't reproduce it.

# Slide Show Sequence
Timer = 15.000000
Loop = 1
FullScreen = 0
PlayMode = 2
WinWidth = 1400
WinHeight = 1050
MouseNav = 0
TitleBar = 0
Fit = 0
StrechVideo = 0
High = 1
CenterWindow = 0
ReadErrors = 0
RandomOrder = 1
ShowText = 0
Text = <File> <Filename> <Size>KB <Width>x<Height> <Date> <Make> <Model>
BackgroundColor = 0
FontName = "Arial"
FontBold = 0
FontItalic = 0
FontHeight = -19
TextColor = c0c0c0
TextPosition = 0
Effect = 0
EffectMask = 16777215

v1.94.2, Vista.
Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Fri Sep 19, 2008 6:05 pm

Anyone? Still not fixed in the beta 2, it's quite annoying, because when I switch images quickly, I found the image I want, but then I can't go back to that image.

To reproduce it just use a mouse wheel (down) to quickly toggle the images, then try to go back (wheel up). Just the same image is 'blinking'. So I can reproduce it only using a mouse wheel, also without Pause key.
Dreamer

User avatar
xnview
Author of XnView
Posts: 32035
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Sep 22, 2008 9:00 am

Dreamer wrote:To reproduce it just use a mouse wheel (down) to quickly toggle the images, then try to go back (wheel up). Just the same image is 'blinking'. So I can reproduce it only using a mouse wheel, also without Pause key.
Do you have always this problem even with no random?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Wed Sep 24, 2008 6:41 pm

Strange, I can't reproduce it now. I need more time to test...
Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Wed Sep 24, 2008 9:21 pm

OK, I can reproduce it again, try this:

- use settings below
- run the slide show
- scroll down, once, to do to second picture
- wait at least 5 seconds
- quickly scroll down, to switch many pictures
- then quickly scroll up to go back to the second picture
- now try to scroll up once
= the same image (second) is blinking also if you try to scroll up again...

# Slide Show Sequence
Timer = 60.000000
Loop = 1
FullScreen = 0
PlayMode = 2
WinWidth = 1400
WinHeight = 1050
MouseNav = 0
TitleBar = 0
Fit = 0
StrechVideo = 0
High = 1
CenterWindow = 0
ReadErrors = 0
RandomOrder = 1
ShowText = 0
Text = <File> <Filename> <Size>KB <Width>x<Height> <Date> <Make> <Model>
BackgroundColor = 0
FontName = "Arial"
FontBold = 0
FontItalic = 0
FontHeight = -19
TextColor = c0c0c0
TextPosition = 0
Effect = 0
EffectMask = 16777215

OK, another problem, with these settings timer is not working at all now!? Perhaps it's the PlayMode = 2 ? But I am sure I have not changed this.

I'll try to create and test new slide shows tomorrow...
Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Thu Sep 25, 2008 8:30 pm

I got it, finally! If the filename/folder is changed/renamed/removed, then switching forward is working good, missing file/folder is skipped and the next image is shown, but when switching backward, it's not working, if the previous image doesn't exist, the same image is shown again and again. I can always reproduce it now.

- create slide show, sld file with 10 pictures (1.jpg - 10.jpg)
- rename 2.jpg to 2a.jpg
- run the slide show
- switch forward
= 2.jpg is skipped, 3.jpg is shown
- switch backward
= just the same image is shown, blinking
Dreamer

User avatar
xnview
Author of XnView
Posts: 32035
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Sep 29, 2008 7:13 am

Ok, i can reproduce now
Pierre.

Post Reply