1.95: maximized window is restored when opening browser

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
jugg
Posts: 5
Joined: Sun Oct 19, 2008 2:52 am

1.95: maximized window is restored when opening browser

Post by jugg » Sun Oct 19, 2008 4:48 am

Hello,

If I have my xnview window maximized without showing the Browser, then if I click on the Browser toolbar button, the Browser opens, but my window is restored (ie, it is no longer maximized).

:edit:
It appears there is a related issue: Have the xnview window in the restored state without showing the Browser, then open the Browser. The window is resized.

In the options dialog->Interface->Windows:
- Use different position/size for browser & view: is UNchecked.
- Remember last window postition/size: is UNchecked.
:end edit:

Regards.

ps. I've submitted a couple of bug reports now, after only using xnview for a short period of time. But I must be sure to say thank you for a very great program too! I've been searching for a useable photo viewer for a long time, and I think I have finally found it! Which is why I'm taking the time to submit the bug reports... I like it! :)

User avatar
xnview
Author of XnView
Posts: 31110
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.95: maximized window is restored when opening browser

Post by xnview » Tue Dec 23, 2008 1:17 pm

I have not this issue if 'Remember last window postition/size' is checked
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Dec 23, 2008 10:34 pm

Thank you for submitting bugs, jugg.

With the following steps I could reproduce the above problem:

1.) Start XnView
2.) Open Browser (if not opened, already)
3.) Browse to a folder with images and open an image by double-clicking
4.) Close the browser
5.) Press symbol to non-maximize the child-window (middle symbol)
6.) Open browser by clicking on "Browser" symbol in toolbar
-> Browser is shown maximized. When switching to the image one can see that the image is maximized, too.

In some cases the "Minimize/reduce/Close" symbol group just vanishes. Looks as if there's a (second) bug.

User avatar
xnview
Author of XnView
Posts: 31110
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Dec 24, 2008 8:19 am

Oh you mean child window, i've tested the main window
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Dec 24, 2008 10:42 am

xnview wrote:Oh you mean child window, i've tested the main window
jugg, do you mean the child window (windows inside the main window) or the main/parent window?

Post Reply