Absolute channel removal

Ideas for improvements and requests for new features in XnView Classic

Moderators: XnTriq, xnview

Post Reply
Hobbe
Posts: 47
Joined: Mon Oct 16, 2006 8:30 pm

Absolute channel removal

Post by Hobbe » Fri Dec 26, 2008 12:52 am

I can't seem to effectively remove color channels from an image using the maximum negative value allowed by the "Colour balance" tool (-100) on a single pass, and at this point I'm not sure how many it would take assuming it's actually possible.

In the examples shown below I tried to remove the red channel:


Image
Original

Image
First-pass with XnView

Image
Second-pass with XnView

Image
First-pass with Photoshop

Can this behavior be improved? thanks :)

User avatar
XnTriq
Moderator & Librarian
Posts: 5364
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Fri Dec 26, 2008 7:30 am

The sliders for Colour balance are broken :bugconfirmed:
  1. Open 2i2947d.png.
  2. Go to Image » Adjust » Brightness/Contrast/Gamma/Balance... or hit Shift+E.
  3. Click the Default values button in the Adjust dialog.
  4. Click twice (no double-click) on the area to the left or the right of the slider.
    » The slider jumps to -60/60, and then to -100/100:

    Image
    [ z00m ]
XnView v1.95.4 @ Windows 2000 SP4

User avatar
xnview
Author of XnView
Posts: 30875
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Absolute channel removal

Post by xnview » Fri Jan 09, 2009 10:56 am

Please try XnView 1.96 beta
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5364
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Absolute channel removal

Post by XnTriq » Sat Jan 10, 2009 11:30 pm

xnview wrote:Please try XnView 1.96 beta
Fixed!

Post Reply