Pb de transparence

Questions générales en Français

Moderators: XnTriq, xnview

Post Reply
Bobvideo

Pb de transparence

Post by Bobvideo » Fri Apr 08, 2005 9:55 pm

J'essaie temps bien que mal de transformer des petites images gif en transparence (image / editer la palette / cocher transparence / je choisi 255 255 255 / ok / puis je sauvegarde l'image), sous xnview d'apres l'apercu l'image est bien en transparence mais dès que je quitte xnview et que je le relance en chargeant la même image, je retourne dans la palette et je vois qu'il ne garde pas 255 255 255, et donc mon image n'est pas transparente, merci de votre aide !

User avatar
helmut
Posts: 8176
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Pb de transparence

Post by helmut » Sat Apr 09, 2005 12:04 pm

Bobvideo wrote:J'essaie temps bien que mal de transformer des petites images gif en transparence (image / editer la palette / cocher transparence / je choisi 255 255 255 / ok / puis je sauvegarde l'image), sous xnview d'apres l'apercu l'image est bien en transparence mais dès que je quitte xnview et que je le relance en chargeant la même image, je retourne dans la palette et je vois qu'il ne garde pas 255 255 255, et donc mon image n'est pas transparente, merci de votre aide !
Normalement cela fonctionne.

Il est important que la colour transparent est selectionnée quand tu presse "OK". Mais j'ai l'impression que ce n'est pas ton problème.

Est-ce que tu utilises un format qui supporte la transparence (gif ou png par exemple)?

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Pareil…

Post by Clo » Sat Apr 09, 2005 1:30 pm

>> Bobvideo
:) Bonjour,

- Je confirme : votre manip est tout à fait correcte; j'ai le même problème : la couleur de transparence choisie n'est PAS enregistrée; quand on ferme / rouvre le fichier, il n'y a aucune modification, pas de fond transparent…
- J'ai testé avec des formats qui assument la transparence (GIF, PNG 256 couleurs - ICO 256 couleurs), ça ne marche pas.

- Espérons que Pierre à une explication, ou pourrait arranger cela…

:mrgreen: Cordialement,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32447
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Pareil…

Post by xnview » Sun Apr 10, 2005 1:47 pm

Clo wrote:- Je confirme : votre manip est tout à fait correcte; j'ai le même problème : la couleur de transparence choisie n'est PAS enregistrée; quand on ferme / rouvre le fichier, il n'y a aucune modification, pas de fond transparent…
- J'ai testé avec des formats qui assument la transparence (GIF, PNG 256 couleurs - ICO 256 couleurs), ça ne marche pas.
Etrange, je viens d'essayer avec un gif, et cela fonctionne. Pouvez vous me donner un gif et un index de transparence ayant le probleme?
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Échantillon…

Post by Clo » Sun Apr 10, 2005 3:56 pm

:) Bonjour Pierre,

- Vous pouvez essayer avec celle-ci
- ICO 256 c. Le fond est à 212/254/212 - si vous l'établissez comme couleur de transparence dans l'aperçu >> Enregistrer >> Rouvrir cette image : pas de transparent, le fond est toujours là !
- J'ai remarqué celà depuis lurette, pour des GIFs faits "maison" par conversion (avec XnView) de BMP, aussi en autres formats 8 BPP, aucun ne marche, le fond revient toujours... quand on rouvre avec XnView, mais ça peut marcher par exemple sur HTML dans un navigateur…
- Je n'ai pas rapporté ce problème car j'utilise la plupart du temps un fond toujours de même couleur que celui des images dans mes travaux, p. ex. les dossiers d'aide HTML, donc un pis-aller acceptable…
- Avec un GIF 32 c., c'est pire : on a pas de transparent pour l'aperçu, juste des nuages de pixels gris par-ci par-là… ?

:mrgreen: Cordialement,
Claude
Clo
Last edited by Clo on Sun Apr 10, 2005 4:05 pm, edited 1 time in total.
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32447
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Échantillon…

Post by xnview » Sun Apr 10, 2005 4:04 pm

Clo wrote:- Vous pouvez essayer avec celle-ci
- ICO 256 c. Le fond est à 212/254/212 - si vous l'établissez comme couleur de transparence dans l'aperçu >> Enregistrer >> Rouvrir cette image : pas de transparent, le fond est toujours là !
- J'ai remarqué celà depuis lurette, pour des GIFs faits "maison" par conversion (avec XnView) de BMP, aussi en autres formats 8 BPP, aucun ne marche, le fond revient toujours... quand on rouvre tout de suite avec XnView, mais ça peut marcher par exemple sur HTML dans un navigateur…
- Je n'ai pas rapproté ce problème car j'utilise la plupart du temps un fond toujours de même couleur que celui des images dans mes travaux, p. ex. les dossiers d'aide HTML, donc un pis-aller acceptable…
- Avec un GIF 32 c., c'est pire : on a pas de transparent pour l'aperçu, juste des nuages de pixels gris par-ci par-là… ?
Désolé, mais je viens d'eesayer en sauvant en PNG ou GIF apres avoir mis l'index 231 comme transparente, et j'ai bien au final cette transparence. Pour l'ico, ceci est normal que la transparence ne soit pas gardée.
Pierre.

User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique
Contact:

Vous avez dit transparent ?

Post by ouistiti » Sun Apr 10, 2005 4:20 pm

Plus rien à comprendre...
1) Je crée des gifs transparent avec XnView... qui chez moi refuse obstinément d'afficher la transparence..., je les sauvegarde et celle-ci ne devient visible qu'avec d'autres logiciels... PSP par exemple...
2) Les gifs, png et ico... créés ailleurs avec transparence et visionnés avec XnView ne sont pas transparents... et pourtant en examinant la palette, la transparence est cochée....Juste un fond tout noir... ce n'est pas évident !

Le mystère reste entier... Je continue à chercher...

Amitiés
Le ouistiti

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Vieux problème…

Post by Clo » Sun Apr 10, 2005 6:18 pm

>>> Ouistiti
:) Bonsoir Paul,
- La transparence (des icônes surtout) est un vieux problème…
Image
- L'icône 256 c. ci-dessus est bien affichée ici ou sur le Bureau de Windows sur transparent. Mais dans XnView, le fond est toujours noir !
Image
Celle-ci a été reconstituée rapidement depuis la première, et traitée dans XnView; elle s'affiche avec transparence ici, mais toujours avec fond tout noir dans XnView…
- Idem-itou pour enregistrer des icônes contenues dans un EXE etc. : l'aperçu est correct, mais l'icône enregistrée a un fond noir, soit inutilisable dans 99% des cas. Je capture la boîte avec l'aperçu, et retaille à la dimension ad-hoc, ainsi j'ai un fond blanc plus utilisable.

:mrgreen: Amicalement,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32447
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Vous avez dit transparent ?

Post by xnview » Mon Apr 11, 2005 10:40 am

ouistiti wrote:Plus rien à comprendre...
1) Je crée des gifs transparent avec XnView... qui chez moi refuse obstinément d'afficher la transparence..., je les sauvegarde et celle-ci ne devient visible qu'avec d'autres logiciels... PSP par exemple...
2) Les gifs, png et ico... créés ailleurs avec transparence et visionnés avec XnView ne sont pas transparents... et pourtant en examinant la palette, la transparence est cochée....Juste un fond tout noir... ce n'est pas évident !
Pour voir les gif/png avec transparence, il faut activer "options/Vue/voir transparence"
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

C'est coché !

Post by Clo » Mon Apr 11, 2005 1:56 pm

>> Pierre
:) Bonjour Pierre,

- L'option est toujours cochée chez moi, et pourtant les fonds d'icônes et d'autres sont toujours noirs…

:mrgreen: Cordialement,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32447
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: C'est coché !

Post by xnview » Mon Apr 11, 2005 5:35 pm

Clo wrote:- L'option est toujours cochée chez moi, et pourtant les fonds d'icônes et d'autres sont toujours noirs…
Pour les .ico, c'est normal, xnview ne gere pas la transparence, par contre les gif/png sont bien affichés.
Pierre.

User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique
Contact:

Post by ouistiti » Tue Apr 12, 2005 10:00 am

XNVIEW à dit :
Pour voir les gif/png avec transparence, il faut activer "options/Vue/voir transparence"
Merci, cela a résolu mon problème pour les gif et png.

Pour les icônes j'attendrai patiemment que XnView gère cette transparence...
:wink:
Amitiés
Paul

Post Reply