RC4: Strange Redrawing when switching thumbnail view

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
helmut
Posts: 8172
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

RC4: Strange Redrawing when switching thumbnail view

Post by helmut » Sat Jun 04, 2005 8:52 am

There's some strange flickering and redrawing when switching in between various thumbnail views.

To reproduce:

1.) In XnView browse a folder with many images (e. 100 images - the more the better).
2.) Press F9 several times to switch between the various types of views for files (Thumbnails, Thumbnails & Details, ...).
-> When switching to "Thumbnails", there is some strange redrawing. One can see the thumbnails, already, but then they are rearranged. This looks odd / wrong.

XnView 1.80 <x>

User avatar
xnview
Author of XnView
Posts: 31741
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC4: Strange Redrawing when switching thumbnail view

Post by xnview » Sat Jun 04, 2005 2:50 pm

helmut wrote:There's some strange flickering and redrawing when switching in between various thumbnail views.

To reproduce:

1.) In XnView browse a folder with many images (e. 100 images - the more the better).
2.) Press F9 several times to switch between the various types of views for files (Thumbnails, Thumbnails & Details, ...).
-> When switching to "Thumbnails", there is some strange redrawing. One can see the thumbnails, already, but then they are rearranged. This looks odd / wrong.
Yes happened sometimes, but i don't know why :-(
Pierre.

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny » Sat Jun 04, 2005 3:34 pm

I know of 2 similar problems but i guess i'll have to wait for RC5. Hopefully i'll remember them. :mrgreen:

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sat Jun 04, 2005 4:25 pm

Confirmed.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sat Jun 04, 2005 4:29 pm

Danny wrote:I know of 2 similar problems but i guess i'll have to wait for RC5. Hopefully i'll remember them. :mrgreen:
Yes, me too, at least one.

Create one txt file in the xnview dir. and use it for such bugs/problems, like me :wink:

User avatar
xnview
Author of XnView
Posts: 31741
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sun Jun 05, 2005 10:33 am

Dreamer wrote:Confirmed.
But do you have a method to reproduce it always??
Pierre.

User avatar
helmut
Posts: 8172
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Sun Jun 05, 2005 10:59 am

xnview wrote:
Dreamer wrote:Confirmed.
But do you have a method to reproduce it always??
For me this happens always. And the more images the more obvious it gets. Active/inactive cache has no influence.

The problem can be seen in RC3 and RC4, in RC2 this works fine.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sun Jun 05, 2005 2:22 pm

xnview wrote:
Dreamer wrote:Confirmed.
But do you have a method to reproduce it always??
Yes, also with default settings.
Dreamer

User avatar
Lesmo16
Posts: 419
Joined: Thu May 12, 2005 8:59 pm
Location: Germany

Post by Lesmo16 » Mon Jun 06, 2005 3:16 pm

I can confirm that with Win XP / SP2.
The flickering occurs when I return to the initial layout after switching through the whole list of thumbnail views (the last F9).
Everyone who believes in telekinesis, raise my hand!

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny » Mon Jun 06, 2005 5:57 pm

Yeah, well... The program is probably just arranging/loading the thumbnails one by one. Nothing to worry about IMO.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Wed Jul 06, 2005 12:13 am

Dreamer wrote:
xnview wrote:
Dreamer wrote:Confirmed.
But do you have a method to reproduce it always??
Yes, also with default settings.
Not fixed in v1.80.1.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Sun Jul 17, 2005 3:53 pm

The strange redraw can also occur when file is downloaded into same directory (auto-refresh on). Like helmut, I only see problem in directory of 100+ thumbnails. I don't see the redraw with 9 thumbnails.

Post Reply