One particular APNG is stuck at first frame

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
MaxSt
Posts: 133
Joined: Fri Apr 10, 2009 9:55 pm

One particular APNG is stuck at first frame

Post by MaxSt » Fri Jun 10, 2011 7:02 pm

That one:

Image

MaxSt
Posts: 133
Joined: Fri Apr 10, 2009 9:55 pm

Re: One particular APNG is stuck at first frame

Post by MaxSt » Wed Jun 22, 2011 4:53 am

It's still static in 1.98.1

User avatar
xnview
Author of XnView
Posts: 32735
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: One particular APNG is stuck at first frame

Post by xnview » Wed Jun 22, 2011 11:52 am

This file seems to have data error...
Pierre.

MaxSt
Posts: 133
Joined: Fri Apr 10, 2009 9:55 pm

Re: One particular APNG is stuck at first frame

Post by MaxSt » Wed Jun 22, 2011 2:36 pm

I copied zstream from first 2 frames into separate PNG files:

Image

Image

They both work just fine, that means there is no zstream data errors.

User avatar
xnview
Author of XnView
Posts: 32735
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: One particular APNG is stuck at first frame

Post by xnview » Thu Jun 23, 2011 8:10 am

right, it's not the problem, but a problem with chunk & libpng...
Pierre.

MaxSt
Posts: 133
Joined: Fri Apr 10, 2009 9:55 pm

Re: One particular APNG is stuck at first frame

Post by MaxSt » Fri Jun 24, 2011 11:46 am

Another example: 2 frames, also stuck at first frame:

Image

User avatar
DOS386
Posts: 291
Joined: Sun Jun 11, 2006 2:43 pm

Re: One particular APNG is stuck at first frame

Post by DOS386 » Sun Oct 21, 2012 2:35 pm

> Another example: 2 frames, also stuck at first frame

Still buggy in 1.99.1. Warns about multiple pages, but neither animation runs, nor I can see other frames as pages :bug:
There is indeed no WinZIP under my rock.

Post Reply