Crash with Autoit script

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
lian
Posts: 226
Joined: Wed Nov 24, 2004 8:53 pm

Crash with Autoit script

Post by lian »

Hello,
some strange problem. I use Autoit Scripts and one of them (not all) make MP crashes. The script is used to save images in Gimp and has nothing to do with MP but each time I use it, MP (in background) stops working.
Here is the code

Code: Select all

#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_outfile=E:\Lian\vrac\scriptsautoit\sauvegarde gimp-xz-2010.exe
#AutoIt3Wrapper_Res_Comment=http://www.hiddensoft.com/autoit3/compiled.html
#AutoIt3Wrapper_Res_Description=AutoIt v3 Compiled Script
#AutoIt3Wrapper_Run_AU3Check=n
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
#Region converted Directives from E:\Lian\vrac\scriptsautoit\sauvegarde gimp-xz.au3.ini
#EndRegion converted Directives from E:\Lian\vrac\scriptsautoit\sauvegarde gimp-xz.au3.ini
;
#include <Date.au3>
AutoItSetOption ( "MouseCoordMode", 0 )
$jour=@MDAY
$mois=@MON
$an=@YEAR
Opt("WinTitleMatchMode", 2)
WinActivate("Calques","")
Sleep(300)
Send("^s")
Sleep(300)
Send("{ENTER}")
Sleep(300)
Send("^r")
Sleep(300)
WinActivate("Échelle et taille de l'image")
Sleep(300)
Send("^c")

$a = ClipGet ( )

Send("!h")
Send("^c")
$b = ClipGet ( )

If $a >= $b Then
	Send("!l")
	Send("800")

Else
	Send("!h")
	Send("850")
EndIf

Send("{ENTER}")
Send("!é")
Sleep(2000)
WinActivate("Calques","")

Send("^+s")
Sleep(200)
WinActivate("Enregistrer l'image")
Send("{END}")
Send("{BS 3}")
Send("jpg")
Send("{HOME}")
$chemin = "c:\images\"
ClipPut($chemin)
Send("^v")
Sleep(300)
Send("{ENTER}")
Sleep(500)
WinWaitActive("Exporter fichier")
WinActivate("Exporter fichier")
Sleep(300)
Send("{ENTER}")
WinWaitActive("Enregistrer en JPEG")
WinActivate("Enregistrer en JPEG")
Send("{ENTER}")



	Exit
SF, illustrations et mes BD sur mon blog: https://www.li-an.fr/
Windows 10 Home 64 bits
User avatar
xnview
Author of XnView
Posts: 43882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Crash with Autoit script

Post by xnview »

MP is opened on same folder?
Pierre.
User avatar
lian
Posts: 226
Joined: Wed Nov 24, 2004 8:53 pm

Re: Crash with Autoit script

Post by lian »

Yes !
SF, illustrations et mes BD sur mon blog: https://www.li-an.fr/
Windows 10 Home 64 bits
User avatar
xnview
Author of XnView
Posts: 43882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Crash with Autoit script

Post by xnview »

It's a known bug
Pierre.
User avatar
lian
Posts: 226
Joined: Wed Nov 24, 2004 8:53 pm

Re: Crash with Autoit script

Post by lian »

OK. I hope there will be a solution :-)
SF, illustrations et mes BD sur mon blog: https://www.li-an.fr/
Windows 10 Home 64 bits