Xnview 2.0 crash on hidden file

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
Ryrynz
Posts: 14
Joined: Mon Jan 09, 2012 9:44 am

Xnview 2.0 crash on hidden file

Post by Ryrynz » Thu Apr 11, 2013 8:34 am

Viewing this file when hidden property is set on my computer causes Xnview to crash and explorer saying "xnview for Windows has stopped working"

User avatar
xnview
Author of XnView
Posts: 32766
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Xnview 2.0 crash on hidden file

Post by xnview » Thu Apr 11, 2013 8:48 am

which OS?
You start with this file from windows explorer?
Pierre.

eL_PuSHeR
Posts: 267
Joined: Sat Apr 25, 2009 9:23 am

Re: Xnview 2.0 crash on hidden file

Post by eL_PuSHeR » Fri Apr 12, 2013 6:55 am

Unable to recreate. It works fine here. Open with -> Xnview. It works also fine from XnView file browser.

XnView 2.0.0.0 under Win7 x64
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

Ryrynz
Posts: 14
Joined: Mon Jan 09, 2012 9:44 am

Re: Xnview 2.0 crash on hidden file

Post by Ryrynz » Fri Apr 12, 2013 12:22 pm

Via Windows Explorer on 7 x64. I get the explorer error generally once the file has displayed.

Scouting around a bit I've found part of the issue, still not sure what's causing it but these two settings in the INI cause the error for me.

PlaySound=0 and ImageLoop=1 =Explorer error

Playsound=1 and ImageLoop=1 =No error
Playsound=0 and ImageLoop=0 =No error

Still have yet to test on my other machine, but will do that when I wake up, tested 1.99.6 and it had the same issue.

Post Reply