0.72 Resize: "Keep ratio" ignored when using "<Last used>"

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
dietmar
Posts: 104
Joined: Fri Oct 25, 2013 4:55 pm

0.72 Resize: "Keep ratio" ignored when using "<Last used>"

Post by dietmar »

Pierre,

the image resize dialog defaults to 'last size used' and re-uses the last used width and height. This contradicts with the 'Keep aspect ration' toggle and meaning.

Example:
Image 1: original size 1498x1146
Open resize dialog, enable 'keep aspect ratio', select default size 800x600
New image will be 800x616 - correct.

Image 2: original size 1498x599
Open resize dialog
Dialog defaults to: 'last size used', width: 800, height: 616, 'keep aspect ratio': on

This can't be correct as the aspect ration of this image is far from the other one.
Either you no longer 'keep aspect ratio', so you have to disable that.
Or the heigth must change to 322 (with the width kept at 800), so that the aspect ratio is kept.
I propose the second, as this was how Classic handled it.

Dietmar
0.72 x32 Linux
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.72 Resizing problem

Post by xnview »

See Issue 603 for current status and details.
Pierre.
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.72 Resizing problem

Post by helmut »

This problem is supposed to be fixed in XnView MP 0.75 or later. Could you please try and confirm the bug fix, dietmar?
dietmar
Posts: 104
Joined: Fri Oct 25, 2013 4:55 pm

Re: 0.72 Resizing problem

Post by dietmar »

helmut wrote:This problem is supposed to be fixed in XnView MP 0.75 or later. Could you please try and confirm the bug fix, dietmar?
Nope. In MP 0.84 x64 I still see this:

- open any image - resize using preset 800x600, keep aspect ratio - works.
- undo
- snip image to half width, full height
- resize using <last use> defaults to the same pixel counts as before with aspect ratio still checked. Which is wrong.

Dietmar
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.72 Resizing problem

Post by helmut »

Thank you for your checking and reporting back, Dietmar.
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.72 Resizing problem

Post by helmut »

Confirmed: When using <Last used> in combination with "Keep ratio" the image is stretched. :bug:
dietmar wrote:Or the heigth must change to 322 (with the width kept at 800), so that the aspect ratio is kept.
Right, "Height" should be adjusted. (This is also what happens when selecting a pre-defined size).
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.72 Resizing problem

Post by xnview »

O.k., thank you, I can also reproduce the problem. Issue 1243 is fixed in next version.
Pierre.
User avatar
xnview
Author of XnView
Posts: 33852
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.72 Resize: "Keep ratio" ignored when using "<Last used>"

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.
Post Reply