XnViewMP Copies files instead of moving them

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
trevzilla
Posts: 29
Joined: Wed Jun 29, 2016 10:32 pm

XnViewMP Copies files instead of moving them

Post by trevzilla » Wed Jun 29, 2016 10:36 pm

This used to work in previous versions, but it seems that it's no longer working.

When I have a bunch of pictures open in the browser window, and click and drag them to a different file in the folder list, I expect the pictures to be moved to that folder and not copied. (The folder is on the same physical HDD) Currently the pictures are being copied, and unless there is an option to change this behavior, I believe it's a bug.

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnViewMP Copies files instead of moving them

Post by XnTriq » Sat Jul 02, 2016 8:00 pm

Welcome to the forum, trevzilla =)
xnview ([url=http://newsgroup.xnview.com/viewtopic.php?p=132795#p132795]Dragging on explorer mode doesn't move, but copy[/url]) wrote:
JMM72 wrote:0.81 64 bit on Windows 7 64 bit.

If I drag a thumbnail (or many) over the thumnail of a folder, the thumbnails are moved. If I drag them over the folder tree, the thumbnails are copied. Tried this on the same folder, just changed if I was doing the move operation over the thumnail or over the folder in the folder tree. I'd like if someone else could confirm this behaviour because I thought it was fixed... Or maybe something in my config is corrupt? I shall check tomorrow deeper.
Issue 879

trevzilla
Posts: 29
Joined: Wed Jun 29, 2016 10:32 pm

Re: XnViewMP Copies files instead of moving them

Post by trevzilla » Sat Jul 02, 2016 8:49 pm

Thanks! I love the software! Looks like it's going to be a good community to be a part of! :) Glad to be here!

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnViewMP Copies files instead of moving them

Post by XnTriq » Sat Jul 02, 2016 9:00 pm

And here's looking forward to your feedback and contributions 8-)

Bolthier
Posts: 3
Joined: Thu Mar 14, 2013 11:47 am

Re: XnViewMP Copies files instead of moving them

Post by Bolthier » Mon Jul 11, 2016 9:01 pm

I got the same bug though it seems to be resolved in the newest version looking at the bug tracker entry. The only problem is that the new version 0.82 is not downloadable at the moment. When will version 0.82 with the fix be released?

Thanks for your work.

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnViewMP Copies files instead of moving them

Post by XnTriq » Mon Jul 11, 2016 10:00 pm

Bolthier wrote:The only problem is that the new version 0.82 is not downloadable at the moment. When will version 0.82 with the fix be released?
Version 0.82 is currently undergoing beta testing.

Bolthier
Posts: 3
Joined: Thu Mar 14, 2013 11:47 am

Re: XnViewMP Copies files instead of moving them

Post by Bolthier » Tue Jul 12, 2016 1:29 pm

XnTriq wrote:Version 0.82 is currently undergoing beta testing.
Thanks for the link.

trevzilla
Posts: 29
Joined: Wed Jun 29, 2016 10:32 pm

Re: XnViewMP Copies files instead of moving them

Post by trevzilla » Fri Aug 19, 2016 1:57 am

Figured I'd do a followup post.

I finally got around to downloading the beta version, and sure enough this bug is fixed in the beta.

Is there a source somewhere where I can find out when the beta is supposed to go live?

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnViewMP Copies files instead of moving them

Post by XnTriq » Fri Aug 19, 2016 3:45 am

trevzilla wrote:I finally got around to downloading the beta version, and sure enough this bug is fixed in the beta.
Thanks for confirming.
trevzilla wrote:Is there a source somewhere where I can find out when the beta is supposed to go live?
As of now, Pierre has not mentioned what his plans are for the release of v0.82.
You can check the announcements in the “MP - General Support” section of the forum or activate Check for program updates (Tools » Settings... » Integration » Integration).

Post Reply