Lossless crop errors

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Lossless crop errors

Postby unplugged » Sat Aug 27, 2016 7:52 pm

Hello,

when I try to losslessly crop some of the images imported directly from Canon sx510hs, I get the error "An error has occured, the lossless rotation can`t be executed." With other images from this camera, it crops but to a seemingly random size. Please see attachment. Some images it crops just fine. I tried multiple SD cards, the same results. The problematic images display correctly and if I crop them normally {shift-x} and save recompressed that works just fine. I`m using the latest version of Xnviewmp.

Any ideas? Thank you.

V
Attachments
IMG_2571.JPG
IMG_2564.JPG

User avatar
XnTriq
Moderator & Librarian
Posts: 5190
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Lossless crop errors

Postby XnTriq » Sat Aug 27, 2016 9:00 pm

Welcome to newsgroup.xnview.com, V :-)

According to the EXIF metadata, the dimensions of your sample are supposed to be 4000×3000 pixels, but it's actually 3000×2090 :-?


unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Re: Lossless crop errors

Postby unplugged » Sat Aug 27, 2016 9:07 pm

Thank you for responding. I couldn`t upload images larger than two megs so I cropped them. They should still produce the errors mentioned though. Or I can upload the full size files somewhere else and post the links.

User avatar
XnTriq
Moderator & Librarian
Posts: 5190
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Lossless crop errors

Postby XnTriq » Sat Aug 27, 2016 9:15 pm

I was suspecting that XnViewMP's lossless cropping algorithm might have been confused by the conflicting values.
Yes, please upload an unprocesssed sample to a hosting site (preferably as ZIP or RAR archive, so the server won't mess with it).

unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Re: Lossless crop errors

Postby unplugged » Sat Aug 27, 2016 9:26 pm

Here goes the link: http://www.uschovna.cz/en/zasilka/KSXHIJRY7TCHC5RE-2LX/

With this image, depending on where you crop, xnviewmp either shows the error message mentioned or crops randomly.

Thank you for investigating :)

User avatar
XnTriq
Moderator & Librarian
Posts: 5190
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Lossless crop errors

Postby XnTriq » Sat Aug 27, 2016 9:45 pm

Thanks for the sample! I'm able to reproduce the bug. (My guess would be that it's related to the EXIF orientation flag.) Hopefully this will soon be fixed.

unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Re: Lossless crop errors

Postby unplugged » Sat Aug 27, 2016 10:36 pm

Thank you for such a quick response. Looking forward to this being fixed as xnview is a tremendous application!

All the best,

V

unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Re: Lossless crop errors

Postby unplugged » Sun Aug 28, 2016 7:12 pm

As a workaround for now, I disabled the "Rotate images according to EXIF orientation tag" in Settings>General. I rotate the images manually Ctrl+Shift+R and the cropping then works fine.

V

User avatar
XnTriq
Moderator & Librarian
Posts: 5190
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Lossless crop errors

Postby XnTriq » Mon Aug 29, 2016 4:15 am

unplugged wrote:As a workaround for now, I disabled the "Rotate images according to EXIF orientation tag" in Settings>General. I rotate the images manually Ctrl+Shift+R and the cropping then works fine.

That confirms my suspicion! I've since posted another report (“Set selection ratio”) for a problem which is obviously related. Perhaps Pierre (the developer of XnView) will be able to resolve several issues by fixing one bug.

unplugged
Posts: 6
Joined: Sat Aug 27, 2016 7:41 pm

Re: Lossless crop errors

Postby unplugged » Wed Oct 26, 2016 11:27 am

Hello,

in .83 the bug still exists. Any chance for correction any time soon?

Thank you,

V

User avatar
xnview
Author of XnView
Posts: 28771
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Lossless crop errors

Postby xnview » Thu Mar 16, 2017 9:14 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

User avatar
helmut
Posts: 8127
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Lossless crop errors

Postby helmut » Tue Mar 21, 2017 5:32 pm

Sample image can be found here: viewtopic.php?p=138703#p138703

Confirmed fixed in 0.85 beta 1.


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 0 guests