0.83 + 0.84betas: Cache problem, re-open modified file

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

0.83 + 0.84betas: Cache problem, re-open modified file

Post by HanVroon » Wed Jan 11, 2017 7:57 am

Cache problem: open a file, modify it and save it, then open again, still original unmodified photo.

To reproduce:
1- Open a photo file and change the levels to something uggly.
2- Save the file with menu File, Save. Replace existing file.
3- Close the tab.
4- Open the file just saved in the Browser again.
The original photo is shown, without the levels modification.
5- Close the file again.
6- In the Browser, just click (not open) another photo, then open the photo just edited again.
7- Now the modified photo is shown.
Seems like a memory cache problem to me.

Best regards,
Han

PS: I reported this bug on 19-10-16 with PM, Pierre created a topic (http://newsgroup.xnview.com/viewtopic.php?f=62&t=33978), now when I wanted to check the status after testing 0.84 beta 4, I saw the topic was gone, so here it is again.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by helmut » Wed Jan 11, 2017 9:00 am

Thank you for the detailed description, HanVroon. I could reproduce the bug with 0.84 beta 4. :bugconfirmed:
HanVroon wrote:... PS: I reported this bug on 19-10-16 with PM, Pierre created a topic (http://newsgroup.xnview.com/viewtopic.php?f=62&t=33978), now when I wanted to check the status after testing 0.84 beta 4, I saw the topic was gone, so here it is again.
Is your post in topic "When a new file is opened, several older files appear to" perhaps your missing bug report?

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by XnTriq » Wed Jan 11, 2017 10:19 pm

HanVroon ([url=http://newsgroup.xnview.com/viewtopic.php?p=126527#p126527]View modus shows wrong picture[/url]) wrote:If "Read one image ahead" and "Keep current image" are unchecked, it's still the same.
The unmodified picture is shown after reopening.
It looks like a "Keep current image" problem, but after closing the image this cache should be cleared, I thing. And after saving to disk the modification should be in cache, not the original.

The only way besides closing/opening XnViewMP is also moving one file ahead or back with Previous/Next file.

HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by HanVroon » Sun Jan 15, 2017 9:42 am

@Helmut: No, that was a different bug, dealing with savings of recently opened files or something, it was solved somewhere in October last year.

@XnTrix: Right, that topic dealt with the same bug, but as you can see it bled to death with a refresh solution. After pressing F5 the thumb is updated (only if you have "Rebuild embedded thumbnail" enabled in Fornmat settings, which is the program default). The modified file just saved however is not shown after re-opening it. I think Pierre thought it was solved, as per his last reply on that topic: "ok, F5 must refresh preview too".

So, still:
After a file has been modified and saved and tab closed, and re-opened from the Browser directly after saving, the modified file from disk should be read and shown, not the original from cache (memory).

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by XnTriq » Sun Jan 15, 2017 10:00 am

Related: Edit Image in View Mode Should Rebuild Thumbnail

(I remember reporting a similar bug in XnView Classic (Reloading of edited PNG images), but I haven't been able to reproduce it since.)

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by helmut » Sun Jan 22, 2017 11:29 pm

This problem is supposed to be partly fixed in 0.84 (Final):
When following the above steps the changed image appears (and not the outdated original).

Remaining problem is that the thumbnail is not updated after changing and saving an image file. :bug:

HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by HanVroon » Tue Jan 31, 2017 11:22 am

Confirmed, re-opening a modified file now shows the modified file (in 0.84 final).
And yes, the thumbnail is only updated in the Browser after pressing F5.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83 + 0.84betas: Chache problem, re-open modified file

Post by helmut » Tue Jan 31, 2017 11:48 am

HanVroon wrote:Confirmed, re-opening a modified file now shows the modified file (in 0.84 final).
And yes, the thumbnail is only updated in the Browser after pressing F5.
Thank you for confirming the bug fix, HanVroon. This bug report will kept in "Bug reports" until the remaining problem has been fixed.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83 + 0.84betas: Cache problem, re-open modified file

Post by helmut » Sat Mar 11, 2017 1:45 pm

helmut wrote:... Remaining problem is that the thumbnail is not updated after changing and saving an image file. :bug:
Related or even identical bug report:
- View modus shows wrong picture

:arrow: Reproduced

Post Reply