0.86 MacOS: "View » Reset X/Y" does not work.

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: helmut, XnTriq, xnview, Dreamer

nglazov
Posts: 4
Joined: Mon May 08, 2017 5:09 pm

0.86 MacOS: "View » Reset X/Y" does not work.

Post by nglazov »

XnView: MP 0.86 - 64 bit
OS: Mac

Propertie of View Reset XY does not work.

Effect: View glitch

To reproduce:
You have to have 2 large images in folder
1. When you are in browser view set option Reset XY to on
2. Open first image
3. Scroll it down
4. Go to next image
Actual behaviour (bug): XY position are the same like on previous image :bug:

Expected behaviour: XY position should be equal 0
User avatar
helmut
Moderator
Posts: 8650
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.86: "View » Reset X/Y" does not work.

Post by helmut »

Same here: I've tried to reproduce your problem on Windows 10 but here it works fine. :? Looks like another XnView problem which occurs on MacOS, only.

What is your setting of "Auto image size"?
nglazov
Posts: 4
Joined: Mon May 08, 2017 5:09 pm

Re: 0.86: "View » Reset X/Y" does not work.

Post by nglazov »

helmut wrote:Same here: I've tried to reproduce your problem on Windows 10 but here it works fine. :? Looks like another XnView problem which occurs on MacOS, only.

What is your setting of "Auto image size"?
The value is "Last used" but i tried different values.
User avatar
xnview
Author of XnView
Posts: 38251
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.86 MacOS: "View » Reset X/Y" does not work.

Post by xnview »

O.k., thank you, I can also reproduce the problem. Issue 1261 is fixed in next version.
Pierre.
User avatar
xnview
Author of XnView
Posts: 38251
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.86 MacOS: "View » Reset X/Y" does not work.

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.