Some image formats show icons not thumbnails

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
kirbyspencer
Posts: 3
Joined: Sat May 11, 2019 10:54 pm

Some image formats show icons not thumbnails

Post by kirbyspencer »

I have Settings/Genera/Display All Formats checked but not all images are displayed. In particular AI files, most PSD files, EPS and PDF. The files are for the CS6 version of AI and PS.I'm on an iMacPro running Mohave 10.14.4.
This is a great program, very fast, very flexible, I was happy to pay for it.
Attached are two JPEGs showing the problem.
Attachments
pdf&ai.jpg
eps,psd.jpg
User avatar
Rick
Posts: 114
Joined: Sat Oct 08, 2005 4:10 pm
Contact:

Re: Some image formats show icons

Post by Rick »

I am not the go-to guy on these issues but a lot of it depends on the publisher of the file format and if they allow for a thumbnail and how they have it configured. I am using Serif Affinity products and the thumbnail used to show but due to a change in the beta, it does so no longer

I will take correction on this but I am not sure it is an XnView problem not is it something that they can fix
--
Rick
cday
XnThusiast
Posts: 2529
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Some image formats show icons

Post by cday »

You both have Ghostscript installed?

From the XnView Wiki :

"Ghostscript is open-source software which enables XnView and related programs to load PostScript-based file formats (PS + EPS + AI) as well as PDF for display, printing, and conversion."

Thumbnails may be another issue, of course.
kirbyspencer
Posts: 3
Joined: Sat May 11, 2019 10:54 pm

Re: Some image formats show icons not thumbnails

Post by kirbyspencer »

I do not have Ghostscript installed, I guess I'll look into that but AI is a very common file format. My expectation is that it would be supported.
kirbyspencer
Posts: 3
Joined: Sat May 11, 2019 10:54 pm

Re: Some image formats show icons not thumbnails

Post by kirbyspencer »

Wow, thank you, I installed Ghostscript 9.27, did a restart of XnView and it worked!
Post Reply