0.93.1 {MPixels} displayed number format not well understable for most humans

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Post Reply
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

0.93.1 {MPixels} displayed number format not well understable for most humans

Post by GeorgD » Sat Jun 15, 2019 2:34 pm

XnView: MP 0.93.1 64bits (Mar 6 2019)
OS: Win 10 1809 64bit DE

Actual behaviour (bug):
1. Go to settings > view > info, click insert>>, image > MPixels. Now, {MPixels} parameter is in the text area. Close with OK.
2. Go to thumbnails list (browse), select 1 file, press enter, press i to display information box.
  • For image up to 99 megapixels, it shows e.g. 20 - fine
  • For image >= 100 mega pixels (many of my stitched panoramas), it displays e.g. 1.8e+2 which is a correct number but I consider it a usability bug :bug: because many people do not even know this number formatting and of the remaining humans, most will need really think what it means exactly: 1.8 times (10 power 2) so it's 1.8*10*10 = 180
Expected behaviour: Always display the number in a format that is well/easy to read for most humans, i.e. plain decimal numbers as a sequence of the digits. It's quite unlikely that pictures will soon have an amount of megapixels that leads to too many digits to read that (even billions work fine).
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

User avatar
xnview
Author of XnView
Posts: 31340
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1 {MPixels} displayed number format not well understable for most humans

Post by xnview » Wed Jun 19, 2019 3:03 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

Post Reply