Old bug again [No Refresh, metadata missing]

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Old bug again [No Refresh, metadata missing]

Post by toyotadesigner » Tue Nov 26, 2019 6:19 am

Hi Pierre, with the new 0941 the old bug returned:

viewtopic.php?f=82&t=39547v

Version 0940 did not have this bug...

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Old bug again

Post by xnview » Wed Nov 27, 2019 2:46 pm

Please describe a way to reproduce
Pierre.

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again

Post by toyotadesigner » Wed Nov 27, 2019 4:38 pm

See the link, we have already discussed this topic

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Old bug again

Post by xnview » Thu Nov 28, 2019 11:05 am

toyotadesigner wrote:
Wed Nov 27, 2019 4:38 pm
See the link, we have already discussed this topic
Could you post a detail way to reproduce within XnView?
Pierre.

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again

Post by toyotadesigner » Thu Nov 28, 2019 12:17 pm

Scenario # 1

01. Start XnView MP
02. Select a RAW/NEF image
03. Open with RPP (RawPhotoProcessor mac OS)
04. Develop the image
05. RPP writes the resulting TIFF to the original directory
06. Temporary image appears for a second in XnView
07. RPP updates the EIXF data of the developed image
08. Final TIFF appears in XnView MP and is sorted next to the original RAW (as specified in the settings -> sort by »Date taken«)
09. TIFF has only filename and Date

Scenario # 2

01. Start XnView MP
02. Select a TIFF image
03. Open with PhotoLine (mac OS)
04. Modify the image
05. Scale down the image
06. Save the image with the same filename as JPEG
07. Final JPEG appears in XnView MP and is sorted next to the original RAW (as specified in the settings -> sort by »Date taken«)
08. JPEG has only filename and Date

Scenario # 3

01. Start XnView MP
02. Select several TIFF images
03. Open with Hugin Panorama Stitcher (mac OS)
04. Stitch the image
05. Hugin writes temporary TIFF files to the original directory
06. Temporary images appears in XnView
07. Hugin performs the final stitch and updates the EIXF data of the panorama image
08. Final TIFF panorama appears in XnView MP and is sorted next to the first original RAW (as specified in the settings -> sort by »Date taken«)
09. TIFF has only filename and Date

Hitting the »fn + F5« key refreshes the thumbnail view and the rest of the data appears in the thumbnails.
Alternatively switching to another directory and back does the same trick.

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Old bug again

Post by xnview » Fri Nov 29, 2019 7:23 am

are you reproduce this problem by using XnView MP tools, and not external app?
Pierre.

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again [No Refresh, metadata missing]

Post by toyotadesigner » Fri Nov 29, 2019 9:38 am

I use XnView only as a light box, not the built-in tools.

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Old bug again [No Refresh, metadata missing]

Post by xnview » Fri Dec 06, 2019 12:45 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Old bug again [No Refresh, metadata missing]

Post by xnview » Fri Dec 20, 2019 10:11 am

This problem is supposed to be fixed in XnView MP 0.94.2. Please check and confirm the bug fix here.
Pierre.

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again [No Refresh, metadata missing]

Post by toyotadesigner » Fri Dec 20, 2019 5:38 pm

Sometimes the bug returns, sometimes everything is ok.

But now there is a new bug: If I select several files in a row and press DELETE, the images are not deleted. They stay there.

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again [No Refresh, metadata missing]

Post by toyotadesigner » Fri Dec 20, 2019 8:31 pm

Another test today and everything seems to work...

Catalina with its bug is driving me mad.

joyeux noël et bonne année!

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
toyotadesigner
Posts: 55
Joined: Sun Apr 10, 2016 7:15 am

Re: Old bug again [No Refresh, metadata missing]

Post by toyotadesigner » Sat Dec 21, 2019 6:46 am

Today I have deleted the current XnView MP version (0.94.2)
Then I deleted all files in ~Library/Caches
Rebooted
Installed XnView MP 0.94.2 again
Opened some TIFF files, scaled them down and saved them as JPEG files.
Everything ok, image data are visible.
Later this weekend I will render some panoramas with Hugin and post the results here.

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

Post Reply