[0.94.1]Zoom textbox steals focus

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
User avatar
BK201
Posts: 48
Joined: Fri Apr 06, 2012 3:43 pm

[0.94.1]Zoom textbox steals focus

Post by BK201 »

XnView: Version 0.94.1 64bits (Nov 21 2019)
Platform: Windows 10 (1703)


Problem 1: The zoom percentage textbox always steals focus of the newest image tab, unless there'is only one tab

Reproduce:
1. Check Option>General>"Allow only one instance of XnView"
2. Open image A, then open image B
3. Press "+" button on keyboard

Expectation:
Image B zoom in

Actual result:
Nothing happened except you typed a "+" into the zoom percentage textbox

Demo:
Image




Problem 2: Your focus can't "escape" once the zoom percentage textbox had it

Reproduce:
1. Open image A
2. Click in the zoom percentage textbox
3. Click on image A (or anywhere of the application), then press "+" button on keyboard

Expectation:
Image A zoom in

Actual result:
Nothing happened except you typed a "+" into the zoom percentage textbox
User avatar
xnview
Author of XnView
Posts: 34704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.94.1]Zoom textbox steals focus

Post by xnview »

BK201 wrote: Tue Nov 26, 2019 8:21 am Problem 1: The zoom percentage textbox always steals focus of the newest image tab, unless there'is only one tab
i can't reproduce, focus is not on zoom field.
Pierre.
User avatar
BK201
Posts: 48
Joined: Fri Apr 06, 2012 3:43 pm

Re: [0.94.1]Zoom textbox steals focus

Post by BK201 »

xnview wrote: Wed Nov 27, 2019 3:01 pm
BK201 wrote: Tue Nov 26, 2019 8:21 am Problem 1: The zoom percentage textbox always steals focus of the newest image tab, unless there'is only one tab
i can't reproduce, focus is not on zoom field.
Did more test, 2 more things need to do

1. You need to double click on image file to open it, dragging images into xnview won't produce such bug
2. Option > general > Mode when starting with a file : normal

If still have problem to reproduce it, please check my config file, it's a fresh new one (only options mentioned above are changed) I used to reproduce it

Config: https://pastebin.com/5B4HtjxS

p.s. My Option>Integration>Paths are (in case it's not included in the ini file):
Use .ini in folder: program
Catalog (.db): program
Thumsnail database: Same as catalog
Other files: program
User avatar
xnview
Author of XnView
Posts: 34704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.94.1]Zoom textbox steals focus

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.

I've sent you a PM
Pierre.
User avatar
BK201
Posts: 48
Joined: Fri Apr 06, 2012 3:43 pm

Re: [0.94.1]Zoom textbox steals focus

Post by BK201 »

xnview wrote: Fri Dec 06, 2019 10:35 am :bugconfirmed: Thanks to your detailed description I can reproduce the problem.

I've sent you a PM
The patched .exe fixed the problem, finally got rid of this annoying bug, thanks! (> 3<)~❤
User avatar
xnview
Author of XnView
Posts: 34704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.94.1]Zoom textbox steals focus

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.94.2. Please check and confirm the bug fix here.
Pierre.
Post Reply