0.96.1: failed recognition of color profile

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

wij
Posts: 4
Joined: Wed May 06, 2020 6:10 am

0.96.1: failed recognition of color profile

Post by wij »

XnView: MP 0.96.1 - 64 bit
OS: Windows 10 (1909) - 64 bit

I use a Samsung NX500 camera configured to create JPEG files in Adobe RGB color space. Unfortunately XnView MP fails to recognize the color profile in these files and interprets the colors as sRGB encoded. As a result XnView MP displays the photos with dull colors. Photoshop CC recognizes the profile and displays the colors correctly.

A sample JPEG file with the problem is uploaded here (for one week).
The permission is to use it only for reproducing the problem and improving XnView MP.

I tried to attach it here directly, but the forum software complained that it is too big.
wij
Posts: 4
Joined: Wed May 06, 2020 6:10 am

Re: 0.96.1: failed recognition of color profile

Post by wij »

Affinity Photo 1.8.3 also correctly recognizes the Adobe RGB profile and displays the colors correctly.

ExifTool reports the following:

Code: Select all

Color Space                     : Uncalibrated
Interoperability Index          : R03 - DCF option file (Adobe RGB)
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

Ok, i'm not able to find the embedded profile
Pierre.
wij
Posts: 4
Joined: Wed May 06, 2020 6:10 am

Re: 0.96.1: failed recognition of color profile

Post by wij »

I think that this article written by Elle Stone gives some explanation: What is embedded color profile information?
Ezatoka
Posts: 12
Joined: Wed May 06, 2020 2:08 pm

Re: 0.96.1: failed recognition of color profile

Post by Ezatoka »

IrfanView or PSPX8 did not say anything about a profile.

But GIMP does show the following:
Image
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

Only Gimp, Photoshop CC & Afinity show correct colors?
Pierre.
wij
Posts: 4
Joined: Wed May 06, 2020 6:10 am

Re: 0.96.1: failed recognition of color profile

Post by wij »

ACDSee 18.2 also shows correct colors. According to the EXIF Tags page an Adobe RGB image is indicated by "Uncalibrated" ColorSpace with an InteropIndex of "R03". It appears that this rationale is not actually standardized - I can not find direct mention of Adobe RGB in CIPA DC-009-2010.

I uploaded again the file here (the link will expire after one week). I have over 2000 JPEG images from Samsung NX500 - most of them are probably in Adobe RGB space referenced via EXIF tags as the uploaded photo.
jiangzhenjerry
Posts: 1
Joined: Fri May 27, 2011 2:50 pm

Re: 0.96.1: failed recognition of color profile

Post by jiangzhenjerry »

Has there been any progress or new thoughts about this issue? I came across a photo from Twitter, one that displays well in the web browser (firefox/chrome) and my handy photo viewer Honeyview. However, the moment I opened it in XnViewMP for editing, I noticed the color looks grayish. And yes, the color profile is Adobe RGB. :shock:
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

jiangzhenjerry wrote: Fri Nov 19, 2021 6:46 pm Has there been any progress or new thoughts about this issue? I came across a photo from Twitter, one that displays well in the web browser (firefox/chrome) and my handy photo viewer Honeyview. However, the moment I opened it in XnViewMP for editing, I noticed the color looks grayish. And yes, the color profile is Adobe RGB. :shock:
could you send a sample file?
Pierre.
Propheticus
Posts: 10
Joined: Tue Aug 16, 2022 6:31 pm

Re: 0.96.1: failed recognition of color profile

Post by Propheticus »

See the same bug in FF for examples: https://bugzilla.mozilla.org/show_bug.cgi?id=1322030
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.5.0 beta. Please check and confirm the bug fix here.
Pierre.
Propheticus
Posts: 10
Joined: Tue Aug 16, 2022 6:31 pm

Re: 0.96.1: failed recognition of color profile

Post by Propheticus »

Checked, does not seem fixed.
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.1: failed recognition of color profile

Post by xnview »

right, related to the change when applying ICC profile. Will be fixed in b2
Pierre.