0.96.2 - Issue moving a category through Edit > Parent

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Gwenael Q.
Posts: 114
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Issue : "Edit... > Parent" command (Categories pane) doesn't allow some moves that shoul be allowed.

To reproduce:

1. In the Categories pane (View > Data pane > Categories), create a category "testing" then a subcategory "subcateg" then a sub-subcategory "categ1" (resulting "path" : "testing|subcateg|categ1"
2. Create, elsewhere (= not under "testing"), an other category "categ1".
3. right-click on it > Edit.. > Parent then choose "testing"
4. Message error "This parent is already a child of current category"

Expected behavior :

XnviewMP should not raise an error and should have moved "categ1" under "testing" with "testing" having now the following structure :

Code: Select all

- testing
   - categ1
   - subcateg
       - categ1

XnViewMP 0.96.2 - 64 bit on Windows 8.1 64bit

Thank you for listening
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.
Gwenael Q.
Posts: 114
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Replicated with XnviewMP 0.97.0 x64 (win 8.1 x64)

Please note that this issue also deals with the "Parent" command

Thank you for listening
Gwenael Q.
Posts: 114
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Still replicated with XnviewMP 0.99.1 x64 (win 8.1 x64).

Thank you for listening
Gwenael Q.
Posts: 114
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Testing with XnviewMP 0.99.4 x64 (win 8.1 x64). : Near to be fixed !

Message error is no more raised, category is moved. But... moving a category through Edit > Parent doesn't update the categories tree. The tree will not update and show the move until a move of another category somewhere else is done.

Thank you for listening
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by xnview »

Gwenael Q. wrote: Wed Dec 08, 2021 2:33 am Message error is no more raised, category is moved. But... moving a category through Edit > Parent doesn't update the categories tree. The tree will not update and show the move until a move of another category somewhere else is done.
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.99.7. Please check and confirm the bug fix here.
Pierre.