0.98: Multiselect - wrong preview

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

MacSass
Posts: 7
Joined: Sat May 20, 2017 5:56 pm

0.98: Multiselect - wrong preview

Post by MacSass »

XnView: MP 0.98 - 64 bit
OS: Windows - 64bit

When doing a multi-select of serveral thumbnails at once by doing a click + hold-shift-click then the preview on second click does not show the picture that was actually clicked (last thumb selected) but it shows the first picture of the second row of the selection.
Not a major issue - but surely not intended behaviour.
When you then "move backwards" (still holding shift key) to change the selection, the behaviour is as expected (last picture of selection shown in preview windows). When you "move forward" further down again, the wrong behaviour is showing again.

Effect: <Different picture in preview window than expected.>

To reproduce:
1. Open a folder with several pictues
2. click on image - it is shown in preview windows
3. Hold shift and click on image further down some rows ... preview shows first picture of second selected row, instead of last picture


Expected behaviour: Always show last picture clicked of a selection.

See attachement for more detailed explanation ...

Regards and thanks for the great piece of software - MacSass
You do not have the required permissions to view the files attached to this post.
MacSass
Posts: 7
Joined: Sat May 20, 2017 5:56 pm

Re: 0.98: Multiselect - wrong preview

Post by MacSass »

Issue still current for 0.98.1.

Regards - MacSass
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.98: Multiselect - wrong preview

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.
MacSass
Posts: 7
Joined: Sat May 20, 2017 5:56 pm

Re: 0.98: Multiselect - wrong preview

Post by MacSass »

Issue still current in 0.98.3 unfortunately ... too low priority :wink:
MacSass
Posts: 7
Joined: Sat May 20, 2017 5:56 pm

Re: 0.98: Multiselect - wrong preview

Post by MacSass »

Hi,
still not fixed in 0.99.7 unfortunately ...

Will you consider to fix this, or you consider it too low priority?
I have not many insight, but I would guess it should not be too hard to fix it, as just the picture shown needs to the be the last one selected ...?

Would be nice if that could be fixed in future update - thanks -

MacSass
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.98: Multiselect - wrong preview

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.98: Multiselect - wrong preview

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.00 beta. Please check and confirm the bug fix here.
Pierre.
User avatar
helmut
Posts: 8705
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.98: Multiselect - wrong preview

Post by helmut »

Works fine for me in 1.00 Beta 2. But sure enough original reporter should double-check and confirm if possible.