Timestamp 1900

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: helmut, XnTriq, xnview, Dreamer

Escal21
Posts: 14
Joined: Tue Nov 27, 2012 6:38 am

Timestamp 1900

Post by Escal21 »

I'm not even sure this is a bug or just my mistake…
— I am dealing with genealogy documents, and I timestamp them all by the date and time of the event they're about, and that works fine
— But when I then try to rename them by the EXIF created date and time, using the rename functionality, year 1900 seems to be a problem, and 1900 files are not even really handled by the rename process
— Then again, if I rename the 1900 files by some other tool and asked the docs to be sorted on the EXIF date created or modified, 1900's docs are not in the right place, as though the XnView/XnView MP could not handle this particular year.
Note however that sorting on Date or Created date works fine, and I checked the consistency of the inconsistency on both XnView and Xnview MP.
As S&G sang, how strange to be seventy in 2021 (but how did it feel in 1900 ?) !
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 37964
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Timestamp 1900

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 37964
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Timestamp 1900

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.3. Please check and confirm the bug fix here.
Pierre.