{Categories} not showing category name in batch rename

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

sesame
Posts: 5
Joined: Sat Mar 12, 2022 12:54 am

{Categories} not showing category name in batch rename

Post by sesame »

I'm trying to rename my images based on the category name (XnView MP's categories) yet it's not showing in the 'New name' nor the final renamed file.

I've attached an screenshot showing what I'm doing. Am I missing some variable similar to {Creation date}?

Thank you 🙂
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43194
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: {Categories} not showing category name in batch rename

Post by xnview »

it works here, categories are associated to your file?
Pierre.
sesame
Posts: 5
Joined: Sat Mar 12, 2022 12:54 am

Re: {Categories} not showing category name in batch rename

Post by sesame »

xnview wrote: ↑Mon Mar 14, 2022 8:18 am it works here, categories are associated to your file?
Apologies, I didn't understand categories (I thought they were color labels), but now I see the difference. {Categories} works for me now if I assign a category, but {Color label} doesn't, unless I'm missing something. See the attached image — you can see that I have a color label applied (it's named a custom name) yet the output file name doesn't show the color label name.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43194
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: {Categories} not showing category name in batch rename

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43194
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: {Categories} not showing category name in batch rename

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.00 beta. Please check and confirm the bug fix here.
Pierre.
sesame
Posts: 5
Joined: Sat Mar 12, 2022 12:54 am

Re: {Categories} not showing category name in batch rename

Post by sesame »

xnview wrote: ↑Mon Mar 28, 2022 10:22 am This problem is supposed to be fixed in XnView MP 1.00 beta. Please check and confirm the bug fix here.
Sorry for the delay. It seems to work, except there is an added (Number) next to all of the color labels. This seems to correspond to the label number—for example, my first red label adds (1), my fourth blue label adds (4). Is there a way to remove this and keep the color label name only?
Screen Shot 2022-04-23 at 9.09.27.png
Screen Shot 2022-04-23 at 9.10.32.png
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43194
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: {Categories} not showing category name in batch rename

Post by xnview »

Please check Beta 4
Pierre.