1.3.1 archive files in detail mode

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

1.3.1 archive files in detail mode

Post by qrti »

A bug fixed in V1.3 is back again: Files from archive can't be opened in detail mode

https://www.xnview.com/mantisbt/view.php?id=2420
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

you can't open an image file in archive?? Preview works?
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

- if I double click an archive the screen shows for the blink of an eye empty placeholder tiles of the archives content, then the screen gets empty
- in the empty screen if I select the filter 'custom' (it is already selected at this time) or if I select 'images', the empty placeholder tiles show up
- if I double click a tile nothing happens, no picture is shown as expected
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

in other mode, it works? which format in archive?
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

it does not work in any mode, the archive format is a normal zip

as I said in my first post, same error as documented here
https://www.xnview.com/mantisbt/view.php?id=2420
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

qrti wrote: Sun Oct 23, 2022 9:20 am it does not work in any mode, the archive format is a normal zip
Strange, on windows?
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

yes, windows 11 22H2
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

could you send me the zip file?
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

it concerns any zip file ...
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

meanwhile I deleted the configuration ini and made a fresh installation, same behavior as before,

but I found a way to show the empty placeholders for zip files without changing filter options,
I added jpg to settings/browser/file list/custom filter/include, now the empty placeholders are displayed, but nothing happens after double clicking on them

Screenshot 2022-10-24 092037.png
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

qrti wrote: Mon Oct 24, 2022 6:33 am it concerns any zip file ...
It works with ZIP, so please send me a sample file?
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

attached an arbitrary zip file ...
Origami.zip
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

i don't understand, no problem with 1.3.1
Capture-1.jpg
You do not have the required permissions to view the files attached to this post.
Pierre.
qrti
Posts: 8
Joined: Wed Jul 03, 2019 6:37 am

Re: 1.3.1 archive files in detail mode

Post by qrti »

I installed on three windows PCs with win11 and a virtual machine with win10 - same effect everywhere no preview of images in zip files and no opening after double clicking them. Sorry I can only report what I experienced.

I went back to version 1.3 no problems there.
User avatar
xnview
Author of XnView
Posts: 43607
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1 archive files in detail mode

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.

As a workaround, if you move the xnview mp folder on destop (for example), it works
Pierre.