1.3.1: Export to Jpeg-XL bug

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

1.3.1: Export to Jpeg-XL bug

Post by Kadet »

XnView: MP 1.3.1 - 64 bit and older
Windows 10 and Windows 11 64bit
AMD processor

When the program starts, everything is fine at first.
But after a while (do more or less some stuff in program), when I click Export and choose the JPEG-XL tab, some images in the output window show something strange or black instead of the correctly encoded image.
You do not have the required permissions to view the files attached to this post.
User avatar
masterjp
Posts: 437
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf, Germany

Re: 1.3.1: Export to Jpeg-XL bug

Post by masterjp »

I have an idea, why you get these colour errors in the export preview with jpeg XL.
I get these errors with 32bit colour depth files or pictures in XnViewMP in older versions.

Please try to convert your picture in 24 bit colour depth
before you export the picture to JPEG XL.
PC: Intel 8700k + Asus Z370-F + 16 GB RAM G.Skill + Asus RTX 3050 OC + Samsung SSD
OS: Windows 10 Pro 64bit 22H2 |
GFX: XN-View 2.51.6 | XnViewMP 1.7.2 | XnConvert 1.100.1 | Adobe Photoshop Elements 2024 | Elements XXL 11 | Paint.Net
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.3.1: Export to Jpeg-XL bug

Post by Kadet »

After few tests...
When XnView start on tab with picture 24 bits, preview bug happens on 32 bits pictures.
If start in 32 bits, error is on other deep bits.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1: Export to Jpeg-XL bug

Post by xnview »

sorry could you explain how to reproduce?
Pierre.
User avatar
masterjp
Posts: 437
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf, Germany

Re: 1.3.1: Export to Jpeg-XL bug

Post by masterjp »

Here is a sample file. I think the alpha channel/transparency is the problem.
Last edited by masterjp on Sun Oct 23, 2022 3:44 pm, edited 2 times in total.
PC: Intel 8700k + Asus Z370-F + 16 GB RAM G.Skill + Asus RTX 3050 OC + Samsung SSD
OS: Windows 10 Pro 64bit 22H2 |
GFX: XN-View 2.51.6 | XnViewMP 1.7.2 | XnConvert 1.100.1 | Adobe Photoshop Elements 2024 | Elements XXL 11 | Paint.Net
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1: Export to Jpeg-XL bug

Post by xnview »

no problem, the preview is correct
Pierre.
User avatar
masterjp
Posts: 437
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf, Germany

Re: 1.3.1: Export to Jpeg-XL bug

Post by masterjp »

I can reproduce the problem.

Here is a video: https://www.dropbox.com/s/ewxjk7ny0uuh4 ... g.mkv?dl=0

Steps:
--------
1. Copy both png files in a directory.
2. Open the directory in browser mode
3. Open the file 32_bit_picture.png from browser mode
4. Export dialog and select jpeg xl (=everything is fine!)
5. Close Export dialog without saving file
6. Use the next picture button in the bar below the menu
6. The Layers_32bit.png open in viewing mode
7. Use Export dialog again and the preview is damaged


32bit_picture.png
This is the picture file with problems, but it is important to open the upper file in export dialog first!
Layers_32bit.png
PC: Intel 8700k + Asus Z370-F + 16 GB RAM G.Skill + Asus RTX 3050 OC + Samsung SSD
OS: Windows 10 Pro 64bit 22H2 |
GFX: XN-View 2.51.6 | XnViewMP 1.7.2 | XnConvert 1.100.1 | Adobe Photoshop Elements 2024 | Elements XXL 11 | Paint.Net
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.3.1: Export to Jpeg-XL bug

Post by Kadet »

xnview wrote: Sun Oct 23, 2022 1:50 pm sorry could you explain how to reproduce?
1. Open XnView MP.
2. Open the directory in (a) browser mode or (b) with picture in tab (24 or 32 bits)
3. Open any picture from browser mode if 2.a
4. Export dialog and select jpeg XL (everything is fine!)
5. Close Export dialog without saving file
6. Change color deep 24 --> 32 or 32 --> 24 bits
7. Use Export dialog again and the preview is damaged

Or if You have mix pictures 24 and 32 bits and first time You try export to jxl 24 bits picture and then try export some 32 bits picture you will see the bug.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1: Export to Jpeg-XL bug

Post by xnview »

ok, i can reproduce, but it seems that output file is correct, the problem is loading. I can reproduce with 'Batch convert' too
Pierre.
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.3.1: Export to Jpeg-XL bug

Post by Kadet »

xnview wrote: Mon Oct 24, 2022 2:47 pm ...but it seems that output file is correct...
Not always. When I was testing this, I once save a bad image.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1: Export to Jpeg-XL bug

Post by xnview »

Kadet wrote: Mon Oct 24, 2022 5:05 pm
xnview wrote: Mon Oct 24, 2022 2:47 pm ...but it seems that output file is correct...
Not always. When I was testing this, I once save a bad image.
Even if you restart XnView?
Pierre.
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.3.1: Export to Jpeg-XL bug

Post by Kadet »

xnview wrote: Tue Oct 25, 2022 7:25 am
Kadet wrote: Mon Oct 24, 2022 5:05 pm
xnview wrote: Mon Oct 24, 2022 2:47 pm ...but it seems that output file is correct...
Not always. When I was testing this, I once save a bad image.
Even if you restart XnView?
Now I don't remember. I was a few weeks ago.
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.3.1: Export to Jpeg-XL bug

Post by Kadet »

Sorry, now I know about what You ask.
Yes, After restart XnView image was broken.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.3.1: Export to Jpeg-XL bug

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
corr
Posts: 132
Joined: Tue Jun 13, 2017 8:00 am

Re: 1.3.1: Export to Jpeg-XL bug

Post by corr »

This image is always broken when I create a JXL from it.
You do not have the required permissions to view the files attached to this post.