Archive browsing does not support Unicode filenames

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
mantis3d
Posts: 31
Joined: Fri Nov 21, 2008 5:37 pm

Archive browsing does not support Unicode filenames

Post by mantis3d »

XnView: MP 1.3.1 - 64-bit
OS: Windows 10 - 64-bit

Archive browsing does not support Unicode filename. If image or folder inside the Archive has Unicode filename, XnView can't show images correctly.

To reproduce:
1, there are a 4 images without Unicode filename. Make a Archivewith them. browse it by xnview MP.
图像 003.png
everything is fine.

and here is the Archive.
Nonunicode.zip
2, Now rename the images to Unicode filename.
图像 004.png
Make a Archivewith them. browse it by xnview MP.
图像 005.png
You can notice that xnview MP can not work with it.

and here is the Archive.
Unicode.zip
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Archive browsing does not support Unicode filenames

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Archive browsing does not support Unicode filenames

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.4.0. Please check and confirm the bug fix here.
Pierre.