1.5.3: Reset 'Auto Image size' no longer works

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
Gingerbread Guy
Posts: 43
Joined: Tue Jan 23, 2007 1:57 pm

1.5.3: Reset 'Auto Image size' no longer works

Post by Gingerbread Guy »

XnView: MP 1.5.3 - 64-bit
OS: Windows 11

Settings - View category - View tab - "Reset 'Auto Image size' setting with next/previous file" is ignored

Effect: display glitch

To reproduce:
1. Settings - View category - View tab - Auto image size: Fit image to window.
2. Check "Reset 'Auto Image size' setting with next/previous file" right below that.
3. Double-click an image in the browser to view it in full screen. Any image that doesn't fill the screen should do.
4. Right-click - Auto image size - Fit image to window width (or height, if that's what makes it fill the screen).
5. Scroll the mouse wheel to move to the next or previous image.

Actual behavior: the new image is displayed with the same zoom setting as before.

Expected behavior: the new image is displayed with the "Fit image to window" zoom setting.

Edit: I skipped a few versions, so I don't recall when this regression was introduced. I first noticed it in 1.5.2.
User avatar
xnview
Author of XnView
Posts: 43828
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.3: Reset 'Auto Image size' no longer works

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43828
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.3: Reset 'Auto Image size' no longer works

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.5.4. Please check and confirm the bug fix here.
Pierre.