swf PlugIn does not work

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

swf PlugIn does not work

Post by helmut » Sat Apr 01, 2006 11:10 am

A user has reported a problem with the swf plugin. The Shockwave files (.swf) are not displayed in XnView. I've tried to reproduce the problem and for me this does not work either.

What I have done to make the swf plugin work:
- Downloaded xswf plugin ("Xswf.dll") and stored it in "..\Plugins".
- Started XnView

For all I know, none of the extra plugins is listed in the dialog "Info > Plugins information", so that's normal. But none of the .swf files are shown.
Does the Xswf plugin really work with XnView 1.82.4? (It is supposed to work with 1.82, see question and answer in topic "Xswf Plugin - Support for Shockwave Flash (swf) file type"). What could be the reason why this does not work?

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Nope---

Post by Clo » Sat Apr 01, 2006 2:49 pm

• Hi !

- Same situation here with 1.82.4 : *.swf doesn't work at all.
Indeed I have the library in the <Plugins> sub-directory.

- With older versions, I could get one frame (no animation), but now, I get the error message (in French) “…unknown format”

- This format is changing continually, in addition… and the compatibility between the old and newest formats is far to be certain…
- I resigned to visit some sites having amusing small free games because they use that format intensively, and it changes too frequently…

- Also, I have <DemoStudio> to make video screen captures; it can produce *.swf (converting the basic *.AVI), but the resulting *.SWFs don't work at all, neither in XnView, nor in any other video viewer. I guess it's because the produced version is out of date.
- Finally : *.swf is not listed in the supported formats. Even stated in the "Displayed items" *peanuts*, still the error message.

- IMHO, a quite up to date plugin migh be available, and one¦we could keep an eye on the evolution of the "Flash" thing, since like I said above, it changes often…

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: swf PlugIn does not work

Post by xnview » Sun Apr 02, 2006 8:50 am

helmut wrote:A user has reported a problem with the swf plugin. The Shockwave files (.swf) are not displayed in XnView. I've tried to reproduce the problem and for me this does not work either.

What I have done to make the swf plugin work:
- Downloaded xswf plugin ("Xswf.dll") and stored it in "..\Plugins".
- Started XnView

For all I know, none of the extra plugins is listed in the dialog "Info > Plugins information", so that's normal. But none of the .swf files are shown.
Does the Xswf plugin really work with XnView 1.82.4? (It is supposed to work with 1.82, see question and answer in topic "Xswf Plugin - Support for Shockwave Flash (swf) file type"). What could be the reason why this does not work?
"Xswf.dll" must be renamed to "Xswf.usr".
Pierre.

User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: swf PlugIn does not work

Post by helmut » Sun Apr 02, 2006 9:35 am

xnview wrote:"Xswf.dll" must be renamed to "Xswf.usr".
Works for me, now :-)

@Pierre: You should let Nikolay Raspopov, the author of several Extra Plugins, know right away that the extension of the Extra PlugIns has changed to "usr". I'm sure he will update the plug-ins right away.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: swf PlugIn does not work

Post by xnview » Sun Apr 02, 2006 10:49 am

helmut wrote:
xnview wrote:"Xswf.dll" must be renamed to "Xswf.usr".
Works for me, now :-)

@Pierre: You should let Nikolay Raspopov, the author of several Extra Plugins, know right away that the extension of the Extra PlugIns has changed to "usr". I'm sure he will update the plug-ins right away.
I have already written something in Extra Plugin thread... :-)
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Same…

Post by Clo » Sun Apr 02, 2006 6:28 pm

—> Pierre

:) Good evening,

- I have renamed the library, now I have :
E:\XnView_alpha\Plugins\Xswf.usr
but that no more works… :|

- Still the "…unknown format" message.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: swf PlugIn does not work

Post by helmut » Sun Apr 02, 2006 6:33 pm

xnview wrote:...
I have already written something in Extra Plugin thread... :-)
I've just browsed the topics and couldn't find any hint or info regarding the .usr extension. It's very important that users do not have to rename files to make things work - things must work out of the box. So this should be changed/fixed a.s.a.p..

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: swf PlugIn does not work

Post by xnview » Mon Apr 03, 2006 1:44 pm

helmut wrote:
xnview wrote:...
I have already written something in Extra Plugin thread... :-)
I've just browsed the topics and couldn't find any hint or info regarding the .usr extension. It's very important that users do not have to rename files to make things work - things must work out of the box. So this should be changed/fixed a.s.a.p..
But it's like that since 1.80 version...
Here:
http://newsgroup.xnview.com/viewtopic.p ... 5&start=15
Pierre.

User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: swf PlugIn does not work

Post by helmut » Mon Apr 03, 2006 5:51 pm

xnview wrote:But it's like that since 1.80 version...
A known problem which is around for several months? Very bad. :-(
In the post of user terryo I've found the info. But do users tell us how XnView works? I think this should remain in the hands of developers.

Pierre, please contact Nikolay Raspopov, the author of the Xswf plugin a.s.a.p.. We have a problem here which has been handled very badly. Let's face it and fix it, now.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Clap, clap !

Post by Clo » Mon Apr 03, 2006 7:04 pm

• Hi !
…Pierre, please contact Nikolay Raspopov, the author of the Xswf plugin a.s.a.p.. We have a problem here which has been handled very badly. Let's face it and fix it, now.
   Image

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken » Tue Apr 04, 2006 11:18 am

Even with the file renamed to .usr, I only get the first frame. The file in question works fine in irfanview and in any browser.
- This format is changing continually, in addition… and the compatibility between the old and newest formats is far to be certain…
Unless the plugin is poorly designed, that is irrelevant. Even the oldest browsers can handle even the newest swf files fine. Why? Because the browsers don't try to handle swf themselves, they just handle the plugin, which in turn handles swf. As long as the xnview plugin simply allows xnview to use the swf plugins from macrowave in a manner similar to the way browsers do, then the format chaning doesn't matter.
Oh the feuhrer, oh the feuhrer, oh the feuhrer's nipples bonk!

User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed May 03, 2006 10:49 pm

* BUMP * - Mr. Gougelet, please.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu May 04, 2006 7:07 am

helmut wrote:* BUMP * - Mr. Gougelet, please.
Helmut :-), i've already contacted Nikolay Raspopov, but no reply...
Pierre.

User avatar
helmut
Posts: 8167
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Fri May 05, 2006 4:34 pm

xnview wrote:
helmut wrote:* BUMP * - Mr. Gougelet, please.
Helmut :-), i've already contacted Nikolay Raspopov, but no reply...
O.k. This this solved, now. I've just unzipped the all the extra plugin packages (Xswf, Xhtml, and Xasc), renamed the plug-in files, re-packed them, and placed the new packages on the download server.

For backup, these are the old links with wrong packages:
Xswf_1.0.0.1.zip
Xhtml_1.0.0.1.zip
Xasc_1.0.0.1.zip

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: swf PlugIn does not work

Post by marsh » Fri May 05, 2006 10:57 pm

helmut wrote:
xnview wrote:"Xswf.dll" must be renamed to "Xswf.usr".
Works for me, now :-)
Does it also require an I.E. flash player installation? I only see "format cannot be determined"- and that only if 'Open With all other formats' is set to 'Xnview'.
Also, the swf appears in hexaview even if other options are against this- a problem which disappears when swf references are erased in '.ini' file.

Post Reply