Skins are not available

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, helmut, xnview

Guest

Post by Guest »

I had 1.61Complete (zip file) I just downloaded 1.70.4Complete (zip file) and the skins folder is there with all the choices but in Options-->Toolbar-->Skin only the default is available and none of the others are showing up. I didn't have that problem in 1.61.
I am using win 98.
Guest

Post by Guest »

Thanx for moving my post to a new thread on its own, originally I just searched for 'skins' here and added my post to another thread :)
User avatar
xnview
Author of XnView
Posts: 43828
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Anonymous wrote:I had 1.61Complete (zip file) I just downloaded 1.70.4Complete (zip file) and the skins folder is there with all the choices but in Options-->Toolbar-->Skin only the default is available and none of the others are showing up. I didn't have that problem in 1.61.
I am using win 98.
Do you have all sub folders in skins folder?

E.g.:
..\skins\Amiga\
..\skins\Art-Ice\
...

Pierre.
Guest

Post by Guest »

Yes the sub-folders are all right there under skins
User avatar
xnview
Author of XnView
Posts: 43828
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Anonymous wrote:Yes the sub-folders are all right there under skins
And you have info.txt on each sub folder?
Pierre.
Guest

Post by Guest »

Yes each one has its own info.txt
for example:

Code: Select all

label="Toolbar 10 (Olivier Parisot)"
width = 25
height = 25
auto = 1
User avatar
helmut
Posts: 8705
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

Perhaps your two installations of XnView are mixed (1.61 and 1.70), and cause the toolbar skins not to appear. As you write, you used the ZIP archive for both versions of XnView. Did you unpack into the same directory or did you use separate directories?

I suggest the following:
1.) First, I'd say that you start your old or new XnView and make sure that in the options, category "Install" you have unchecked "Use registry to save options". Then you exit XnView.
2.) Unpack XnView 1.70 into a brand-new directory and start it from there.
I'm quite sure that you will see the skins in the options, then.

Now comes the fine tuning:
If you want to keep your old bookmarks, you exit XnView and then copy the file 'bookmark.ini' from the old program folder of XnView to the new program folder.
I'd be hesitant to copy the 'xnview.ini'. Normally the .ini file is compatible, but this is theory...

If you want to use the registry for saving the XnView options, you can active the setting "Use registry to save options", again.

Hope this helps, Helmut
Guest

Post by Guest »

Thanx for the help but I unpacked new one into a separate directory and I am sure I didn't have the "Use registry to save options" checked in the old version unless it was checked by default which I don't think was the case.

Since I had the zip file from the older version on my HD, I started from scratch I followed your steps by removing both versions and then unpacking older version first...no problem with skin and registry setting is unchecked then I removed old and unpacked new one (in different directory eventhough I had already removed older version) but skin doesn't show up.

Skin is not really important as the program is great so I can live without the skins but its up to you obviously if you want to trace a potential problem
User avatar
helmut
Posts: 8705
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

Thank you for your feedback. Really strange problem - at the moment I have no idea.
Guest

Post by Guest »

Hi everyone!

I'm running XnView 1.80.3 (Sep 6 2005) on a fully patched Windows 2000 SP4 and I've been dealing with this problem, too.
Maybe I've found a workaround.

It seems that XnView is checking for the time/date stamps of the subdirectories in the "\skins" folder for some reason.
A skin will only show up in the program's list of available skins, if the subdirectory it is saved in has a date that's newer than the version of your XnView.

Try this:
Create copies of the subdirectories in the "\skins" folder, then delete the original ones and start XnView again.

Works for me... :P
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

To upgrade---

Post by Clo »

:arrow: Starter Guest

:) Hello !

• I had not these troubles under Win 98 SE with the previous versions you quote…

• A bit aside :
- If you upgrade to 1.80.3, you must change all skins, because they have been modified since the 1.80 version. Now, the file info.txt must contain an extra line, i.e. :
label = "Mus_23 (Claude Charries)"
filename = "main.bmp"
disabled = "blurred.bmp"
browser = 1
auto = 1
small = "browser.bmp"
width = 23
height = 24
version = 2
This line shows that the skin is designed for XnView 1.80 and newer…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
Guest

Post by Guest »

As it turns out, what I posted earlier about time/date stamps wasn't quite right. Sorry 'bout that. :?
(Note to self: Never post on an open forum when you're tired.)

@Clo: Thanks for your comment!

Of course you're right, info.txt now has to include a "version = 2" line.
But still, there seems to be some sort of bug concerning the way XnView is handling skins, and after further experementing today I think I got to the bottom of this.

I deleted all subfolders from the "\skins" directory.
Then I created 2 new subfolders called "test_1" and "test_2".
I put an info.txt in each of these folders.

Code: Select all

label = "Test 1"
width = 24
height = 24
browser = 1
auto = 1
version = 2
and

Code: Select all

label = "Test 2"
width = 24
height = 24
browser = 1
auto = 1
version = 2
I also copied two 24bit/truecolor .BMP files into each folder:
- main.bmp (w792xh24 pixels)
- browser.bmp (w128xh16 pixels)

I removed the archive attribute from the info.txt file in the "test_1" folder, and I made sure that the info.txt file in the "test_2" folder had the archive attribute set.

When I started XnView, only the default and the "Test 2" skin appeared in the list.
So it appears to me as if XnView "sees" only those skins whose info.txt has its archive attribute set.

Anyone plz correct me if i'm wrong here!

BTW: Where can I get the "Mus_23 (Claude Charries)" skin?

WW (Guest #2)
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Works with <none>

Post by Clo »

:) Hello !
- It seems that all info.txt files have the <a> attribute @ home, but I've ckecked removing the attribute for the example I have shown above -so <none>-, and the skin works still under Win 98 SE…

- You can get my own skins from THIS PAGE, and also the Manual I make for years just below… ;)

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
Guest

Post by Guest »

Hello Clo!

Merci beaucoup de votre réponse rapide. :)

Your name sounded familiar to me, probably because I already downloaded your Help-gb.chm file as an additional resource to the regular help file provided with XnView.
and the skin works still under Win 98 SE…
Hm. Could it be a Windows 2K only problem?
I certainly agree with Guest #1:
Skin is not really important as the program is great so I can live without the skins but its up to you obviously if you want to trace a potential problem
Since I got the skins working on my machine, it's just curiosity that makes me wonder what lies behind this "mystery".
Perhaps Monsieur pierre.g will look into this and shed some light on the matter, if he finds the time.

WW
User avatar
xnview
Author of XnView
Posts: 43828
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Anonymous wrote: I removed the archive attribute from the info.txt file in the "test_1" folder, and I made sure that the info.txt file in the "test_2" folder had the archive attribute set.

When I started XnView, only the default and the "Test 2" skin appeared in the list.
So it appears to me as if XnView "sees" only those skins whose info.txt has its archive attribute set.
Strange, ok i check...
Pierre.