Faint grid overlayed on high quality downsampled view

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
captaincavern
Posts: 37
Joined: Fri Dec 13, 2013 6:31 am

Faint grid overlayed on high quality downsampled view

Post by captaincavern » Tue Jan 05, 2016 1:11 pm

I've only noticed this since I connect my monitor through DVI, I guess the minute amount of ghosting it suffered when using VGA connection was masking it.

It's very annoying when viewing line art drawings as it's most visible for me on full white.

Could this be fixed? Thanks in advance.

Edit: it's not noticeable on photos and the best way to "see" it if you don't see it is to make a screenshot of a downsampled view of a fully white image. After opening the screenshot and cropping the client area, counting colors reveals there are two colors instead of one as it should be. Using mehdi's plugin Local equalization on that screenshot will amplify local contrast and make this grid obvious. Grid density depends apparently on zoom level.

User avatar
XnTriq
Moderator & Librarian
Posts: 5534
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Faint grid overlayed on high quality downsampled view

Post by XnTriq » Tue Jan 05, 2016 3:00 pm

captaincavern wrote:Still having this problem, can something be done about it?
XnView Classic or MP or both, Cap'n?

captaincavern
Posts: 37
Joined: Fri Dec 13, 2013 6:31 am

Re: Faint grid overlayed on high quality downsampled view

Post by captaincavern » Tue Jan 05, 2016 4:00 pm

XnTriq wrote:
captaincavern wrote:Still having this problem, can something be done about it?
XnView Classic or MP or both, Cap'n?
Classic, I wouldn't know about MP as I don't use it. And of course this for both issues/topics, this one and the one you've quoted me from.


captaincavern
Posts: 37
Joined: Fri Dec 13, 2013 6:31 am

Re: Faint grid overlayed on high quality downsampled view

Post by captaincavern » Tue Jan 05, 2016 9:05 pm

No need for uploading a sample as any image will do. Here are however the grids showing up when seeing a 100% white image at a couple of different zooms:

Viewed at 77%:
Image

Viewed at 61%:
Image

This is not what it actually looks like of course, I've maximized the contrast as to illustrate those grids, what shows as black above (0,0,0) is actually only 254,254,254.

There should be no such grids at all, all pixels should be white.

User avatar
XnTriq
Moderator & Librarian
Posts: 5534
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Faint grid overlayed on high quality downsampled view

Post by XnTriq » Tue Jan 05, 2016 9:30 pm

Bug confirmed :bugconfirmed:

User avatar
XnTriq
Moderator & Librarian
Posts: 5534
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Faint grid overlayed on high quality downsampled view

Post by XnTriq » Tue Jan 05, 2016 9:45 pm

Steps to reproduce:
  1. Tools » Options... » View » View
    • Zoom step: [ Default ]
    • High quality zoom: [×] Reduce
  2. Capture the entire screen (Print Screen).
  3. Edit » Import Clipboard
  4. Edit » Background colour...: R255/G255/B255
  5. Edit » Select All
  6. Edit » Clear
  7. View » Zoom: 30%
  8. Capture the entire screen (Print Screen).
  9. Edit » Import Clipboard
  10. Select the white area in the imported screenshot.
  11. Edit » Crop
  12. Image » Map » Normalize
Attachments
p129551.png
Result
p129551.png (166 Bytes) Viewed 1172 times

Post Reply