Problem with Preview pane in Ver 1.79

XnConvert Multi Platform - Windows, MacOSX, Linux
Post Reply
Daguerre
Posts: 22
Joined: Sat Oct 01, 2016 12:33 pm

Problem with Preview pane in Ver 1.79

Post by Daguerre » Mon Feb 04, 2019 7:46 pm

I have just updated to XnConvert Ver 1.79 from Ver 1.77. Because it was easier to see the results the following applies to batch cropping of a number of files in a folder.

With Ver 1.77, if I changed one of the cropping values the change immediately appeared in the Preview pane. Furthermore, I could immediately use the Next File and Previous File arrows to move through the cropped files looking for any particular problems with the crops. (I did not have to select the After tab, XnView just showed the cropped files of its own accord.)

Now that I have changed to Ver 1.99 life has suddenly become much more complicated. For example, I make a change to the cropping values and now I first need to ensure that the Before tab is selected and then use the Previous File and Next File arrows to get to a possibly problem file. I then have to press the Apply Action arrow, something that was not needed with Ver 1.77. But I’m still not there. Next I need to press the After tab to see the cropped file.

And now comes the major problem. To look for any cropping problems I now attempt to scan through the cropped files using the Next File and Previous File arrows. And nothing happens! Yes, the file number at the bottom right corner increments or decrements but the preview screen remains stubbornly stuck on the file that I started with!

To see how a different file has been cropped. I need to go back to the Before view, move to a new file and go through the whole sequence again. I need to keep on repeating the whole tedious process time and again to see how the changed cropping values have panned out across a number of files.

Help! How do I get back to the idyllic state that existed before I moved to Ver 1.79?

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with Preview pane in Ver 1.79

Post by xnview » Tue Feb 05, 2019 8:55 am

Daguerre wrote:
Mon Feb 04, 2019 7:46 pm
With Ver 1.77, if I changed one of the cropping values the change immediately appeared in the Preview pane. Furthermore, I could immediately use the Next File and Previous File arrows to move through the cropped files looking for any particular problems with the crops. (I did not have to select the After tab, XnView just showed the cropped files of its own accord.)

Now that I have changed to Ver 1.99 life has suddenly become much more complicated. For example, I make a change to the cropping values and now I first need to ensure that the Before tab is selected and then use the Previous File and Next File arrows to get to a possibly problem file. I then have to press the Apply Action arrow, something that was not needed with Ver 1.77. But I’m still not there. Next I need to press the After tab to see the cropped file.
I can't reproduce this behavior, could you make a screen record?
And now comes the major problem. To look for any cropping problems I now attempt to scan through the cropped files using the Next File and Previous File arrows. And nothing happens! Yes, the file number at the bottom right corner increments or decrements but the preview screen remains stubbornly stuck on the file that I started with!

To see how a different file has been cropped. I need to go back to the Before view, move to a new file and go through the whole sequence again. I need to keep on repeating the whole tedious process time and again to see how the changed cropping values have panned out across a number of files.
Sorry but i don't understand the problem?
Pierre.

Daguerre
Posts: 22
Joined: Sat Oct 01, 2016 12:33 pm

Re: Problem with Preview pane in Ver 1.79

Post by Daguerre » Tue Feb 05, 2019 4:50 pm

I'll try my best to illustrate the particular problem of not being able to scan through the edited files. The example I have chosen is a folder of jpegs of 144 scanned pages of an old paperback that I am converting to a pdf file so that I can get rid of it.

Edit: I forgot that attachments appear in reverse order in a post. #1 is at the bottom and #4 at the top. :wink:

I opened the files in XnConvert Ver 1.79 x64, entered the cropping values and ran it using the Apply action arrow. Attachment #1 shows a typical page - note the Before tab is selected. Also note that the bottom RH tab says that it is file number 60.

I now select the After tab. Attachment #2 shows,as expected, the cropped version. Note that the After tab is selected and that the file number at the bottom RH corner shows file number 60.

I now press the Next file arrow. Attachment #3 shows the result. The bottom RH corner shows that the file has been incremented to number 61, but the screen Preview pane has not changed.

I now press the Next file arrow again. Attachment #4 shows the result. The bottom RH corner now shows that the file has been incremented to number 62 but, yet again, the Preview pane has not changed.

Why is this? With Ver 1.77 I could scan through the edited files using the two bottom LH arrows.
Attachments
#4.JPG
#3.JPG
#2.JPG
#1.JPG

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with Preview pane in Ver 1.79

Post by xnview » Tue Feb 05, 2019 6:51 pm

I can't reproduce, the icon Previous/Next works. Do you have added the files with 'add folder'?
Pierre.

Daguerre
Posts: 22
Joined: Sat Oct 01, 2016 12:33 pm

Re: Problem with Preview pane in Ver 1.79

Post by Daguerre » Tue Feb 05, 2019 10:27 pm

Yes, I used Add Folder.

Daguerre
Posts: 22
Joined: Sat Oct 01, 2016 12:33 pm

Re: Problem with Preview pane in Ver 1.79

Post by Daguerre » Tue Feb 05, 2019 11:26 pm

I've just discovered something rather curious. I was experimenting and decided to try the Update Preview icon, an icon that I've never really noticed before. Anyway it seems to toggle on and off whether I can step through the files in the After view.

Another curious thing. Toggling this icon makes the icon itself increase and decrease ever so slightly in size - it's barely noticeable.

I shall do a bit more playing around with it tomorrow.

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with Preview pane in Ver 1.79

Post by xnview » Wed Feb 06, 2019 9:02 am

i can't reproduce :( if oyu have a folder with 10 images, are you able to reproduce? If you click on button > below preview icon, previes is refreshed?
Pierre.

Daguerre
Posts: 22
Joined: Sat Oct 01, 2016 12:33 pm

Re: Problem with Preview pane in Ver 1.79

Post by Daguerre » Thu Feb 07, 2019 7:21 pm

Firstly an admission of an error. I said above that the Update Preview icon appeared to change size, Actually, looking at it the following morning it was clear that what I was seeing was the little border that normally appears around icons when they are selected.

As suggested, I have tried a folder with ten files in it and also, ten files directly. I also tried two files a and even one file. In all cases the result was the same; as long as I had selected Update Preview and After, then the Preview Pane followed anything I did without any further action needed from me. For example, I enter a new value for the amount of left hand cropping and the change immediately appears in the Preview pane. I then move to the following file and I immediately see the effect of the change on it.

So, for whatever reason, I'm now back to how things used to be, and very glad for that.

And thank you for taking an interest in my problem.

cday
XnThusiast
Posts: 2212
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Problem with Preview pane in Ver 1.79

Post by cday » Thu Feb 07, 2019 7:59 pm

I have sometimes noticed that whereas generally a preview appears immediately when an action is selected, other times a preview is only displayed after clicking the 'Apply actions' (Update) button. Possibly related to particular actions??

I reported that a while back and I think Pierre acknowledged it, but my report contained no more detail than the above, and I regret I don't have XnTriq's amazing search powers... :(

User avatar
XnTriq
Moderator & Librarian
Posts: 5457
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Problem with Preview pane in Ver 1.79

Post by XnTriq » Sat Feb 09, 2019 8:15 pm

cday wrote:
Thu Feb 07, 2019 7:59 pm
I have sometimes noticed that whereas generally a preview appears immediately when an action is selected, other times a preview is only displayed after clicking the 'Apply actions' (Update) button. Possibly related to particular actions??

I reported that a while back and I think Pierre acknowledged it, but my report contained no more detail than the above, and I regret I don't have XnTriq's amazing search powers... :(
Is this…

Bug tracker: Batch convert: Preview 'after' not always loaded
Forum: XnViewMP 0.90 - Batch convert -> action -> preview window does not update

… the report you're referring to, cday?

cday
XnThusiast
Posts: 2212
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Problem with Preview pane in Ver 1.79

Post by cday » Sat Feb 09, 2019 8:22 pm

XnTriq wrote:
Sat Feb 09, 2019 8:15 pm
cday wrote:
Thu Feb 07, 2019 7:59 pm
I have sometimes noticed that whereas generally a preview appears immediately when an action is selected, other times a preview is only displayed after clicking the 'Apply actions' (Update) button. Possibly related to particular actions??

I reported that a while back and I think Pierre acknowledged it, but my report contained no more detail than the above, and I regret I don't have XnTriq's amazing search powers... :(
Is this…

Bug tracker: Batch convert: Preview 'after' not always loaded
Forum: XnViewMP 0.90 - Batch convert -> action -> preview window does not update

… the report you're referring to, cday?

Thank you XnTriq, I thought the issue had already been acknowledged.

But possibly not fully resolved yet, difficult as it has always seemed to be hard to reproduce consistently...

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with Preview pane in Ver 1.79

Post by xnview » Sat Feb 16, 2019 1:14 pm

Daguerre wrote:
Tue Feb 05, 2019 11:26 pm
I shall do a bit more playing around with it tomorrow.
which windows do you use?
Pierre.

Post Reply