JPeg 2000 images distorted or not displayed

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
canis
Posts: 10
Joined: Sat Jun 05, 2004 6:37 am
Location: München / Germany
Contact:

JPeg 2000 images distorted or not displayed

Post by canis » Wed Jun 09, 2004 9:53 am

Hi,

thanks for your fine program! I am using Version 1.70.2 on Windows 2000.

I archive my pictures using JPeg 2000. When trying to browse them with xnView I get only distortions in some cases in other cases I get nothing. When trying to browse with IrfanView, I can see the pictures without problems.

The files are created using PhotoShop CS with jp2 compatibility set to yes.

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with jpeg 2000

Post by xnview » Thu Jun 10, 2004 11:21 am

canis wrote:thanks for your fine program! I am using Version 1.70.2 on Windows 2000.
I archive my pictures using JPeg 2000. When trying to browse them with xnView I get only distortions in some cases in other cases I get nothing. When trying to browse with IrfanView, I can see the pictures without problems.
The files are created using PhotoShop CS with jp2 compatibility set to yes.
Which plugin do you have? Luratech (lwf_jp2.dll) or Xjp2.dll?
Could you send me a sample?
Pierre.

Guest

Re: Problems with jpeg 2000

Post by Guest » Thu Jun 10, 2004 8:22 pm

xnview wrote:
canis wrote:thanks for your fine program! I am using Version 1.70.2 on Windows 2000.
I archive my pictures using JPeg 2000. When trying to browse them with xnView I get only distortions in some cases in other cases I get nothing. When trying to browse with IrfanView, I can see the pictures without problems.
The files are created using PhotoShop CS with jp2 compatibility set to yes.
Which plugin do you have? Luratech (lwf_jp2.dll) or Xjp2.dll?
Could you send me a sample?
Pierre.
For what program do you ask for?

Let me try for both:

Photoshop: JP2KLib from Adobe
IrfanView: JPEG2000.dll based on SDK from Luratech

Sure, I'll send you some different samples. Just trying to get some neat little ones.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Problems with jpeg 2000

Post by helmut » Thu Jun 10, 2004 8:29 pm

xnview wrote:Which plugin do you have? Luratech (lwf_jp2.dll) or Xjp2.dll?
Could you send me a sample?
Pierre.
Pierre means the plug-ins used/installed in XnView. You can find out via menu 'Info->Plug-In Information' in XnView.

canis
Posts: 10
Joined: Sat Jun 05, 2004 6:37 am
Location: München / Germany
Contact:

Post by canis » Thu Jun 10, 2004 8:45 pm

helmut wrote:
xnview wrote:Which plugin do you have? Luratech (lwf_jp2.dll) or Xjp2.dll?
Could you send me a sample?
Pierre.
Pierre means the plug-ins used/installed in XnView. You can find out via menu 'Info->Plug-In Information' in XnView.
Thanks. I just looked: They do exist both. I found out more in the meantime:

It works with 8-Bit-color depth and extension .jp2 It does not work with my favorite 16-bit color depth.

I just send the files.

Thanks for your help!

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jun 17, 2004 9:12 am

canis wrote:It works with 8-Bit-color depth and extension .jp2 It does not work with my favorite 16-bit color depth.
Only Lurawave jpeg 2000 plugin works with 16bits per channel!
Pierre.

canis
Posts: 10
Joined: Sat Jun 05, 2004 6:37 am
Location: München / Germany
Contact:

Post by canis » Thu Jun 17, 2004 12:09 pm

xnview wrote:Only Lurawave jpeg 2000 plugin works with 16bits per channel!
Pierre.
So there is no chance, that you support it? I thought it is one of the main advantages of jp2.

Sorry, but if so, I will go on using vallen jpegger for my browsing, because I can not see an advantage in using XnView for me, only the disadvantage, that I can not write the cache to CD.

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jun 17, 2004 1:18 pm

canis wrote:
xnview wrote:Only Lurawave jpeg 2000 plugin works with 16bits per channel!
Pierre.
So there is no chance, that you support it? I thought it is one of the main advantages of jp2.

Sorry, but if so, I will go on using vallen jpegger for my browsing, because I can not see an advantage in using XnView for me, only the disadvantage, that I can not write the cache to CD.
Remove Xjp2.dll and use lwf_jp2.dll plugin
Pierre.

Guest

Post by Guest » Sat Jun 19, 2004 12:55 am

[quote="xnview]Remove Xjp2.dll and use lwf_jp2.dll plugin
Pierre.[/quote]

I removed Xjp2.dll, but it still does not work with the examples I send to you. Is there any trick how to "use" lwf_jp2.dll ?

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sat Jun 19, 2004 11:06 am

Anonymous wrote:I removed Xjp2.dll, but it still does not work with the examples I send to you. Is there any trick how to "use" lwf_jp2.dll ?
Ok, it's a bug with lwf_jp2.dll, i fix it.
Pierre.

canis
Posts: 10
Joined: Sat Jun 05, 2004 6:37 am
Location: München / Germany
Contact:

Post by canis » Sat Jun 19, 2004 4:54 pm

xnview wrote:Ok, it's a bug with lwf_jp2.dll, i fix it.
Pierre.
Many thanx!

canis
Posts: 10
Joined: Sat Jun 05, 2004 6:37 am
Location: München / Germany
Contact:

Post by canis » Tue Jun 22, 2004 6:43 am

Thanx for the wonderful new Version 1.70.3 !!!

Now I can view my jpeg files with 16-Bit-Colors!

The only drawback I can see is that only files with extension jp2 are handled, but not the files with extension jpf. Do I have to do something so that they are also recognized? If making batchprocessing in PaintShop it insists in using the non-standard extension jpf on output. I may rename them all, but that is a little bit annoying.

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jun 22, 2004 7:36 am

canis wrote:The only drawback I can see is that only files with extension jp2 are handled, but not the files with extension jpf. Do I have to do something so that they are also recognized? If making batchprocessing in PaintShop it insists in using the non-standard extension jpf on output. I may rename them all, but that is a little bit annoying.
Ok, i add jpf for lurawave plugin.
Pierre.

Post Reply